PROBLEM

Unable to perform network analysis in Portal for ArcGIS and ArcGIS Pro

Last Published: April 25, 2020

Description

In some cases, attempts to perform network analysis in Portal for ArcGIS or ArcGIS Pro fail, and return generic error messages without detailed information on the network analysis tool's failure.

For example, performing network analysis using the Create Drive-Time Areas tool in Portal for ArcGIS Map Viewer fails, and returns the following error in the ArcGIS Server Manager logs:

Error:   
Error executing tool. CreateDriveTimeAreas Job ID: <Job_ID> : A geoprocessing error occurred. Failed to execute (Generate Service Areas). Parameters are not valid. Cannot set input into parameter <Network_Dataset>. {"messageCode": "AO_100028", "message": "CreateDriveTimeAreas failed."} Failed to execute (CreateDriveTimeAreas).

Additionally, performing network analysis using the Generate Service Areas tool in ArcGIS Pro fails, and returns the following error in the ArcGIS Server Manager logs:

Error:   
Error executing tool. GenerateServiceAreas Job ID: <Job_ID> : A geoprocessing error occurred. ERROR 000622: Failed to execute (Generate Service Areas). Parameters are not valid. ERROR 000628: Cannot set input into parameter <Network_Dataset>. Failed to execute (GenerateServiceAreas). Failed to execute (GenerateServiceAreas).

Cause

Network analysis uses StreetMap Premium data that has a unique data license version. Therefore, the error occurs through one of the following conditions:

  • The StreetMap Premium data license is expired.
  • The versions of the StreetMap Premium data and their licenses do not match.

Solution or Workaround

To resolve the error, complete the steps described below:

  1. Remove the expired StreetMap Premium data license from ArcGIS Administrator. Refer to ArcMap: Adding and removing ArcGIS data licenses for steps to do so.
  2. Obtain a new StreetMap Premium data license from Esri customer service.
Note:
Ensure the StreetMap Premium data license matches the StreetMap Premium data version. For example, ArcGIS StreetMap Premium North America 2019 Release 1 requires its unique data license version, na_fgdb_2019.1_<map_name_expiry_date>.
  1. Add the StreetMap Premium data license to ArcGIS Administrator. Refer to ArcMap: Adding and removing ArcGIS data licenses for steps to do so.
  2. Restart the Windows services for Portal for ArcGIS and ArcGIS Server.
    1. Right-click the Windows taskbar, and select Task Manager to open Windows Task Manager.
    2. In the Task Manager window, click the Services tab.
    3. Right-click Portal for ArcGIS, and click Restart.
    4. Right-click ArcGIS Server, and click Restart.

Article ID:000022728

Software:
  • ArcGIS Server
  • Portal for ArcGIS
  • ArcGIS Pro

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