English

How To: Convert 3D shapefiles to 2D shapefiles

Summary

In some instances, a 3D shapefile containing 3D features must be converted to a 2D shapefile for further data analysis that requires 2D features. This article provides the instructions on how to convert 3D shapefiles to 2D shapefiles in ArcMap.

Procedure

Convert 3D point, line and polygon features

To convert a 3D shapefile to a 2D shapefile, follow the steps below:

  1. Add the 3D shapefile into ArcMap.
  2. Create a new 2D shapefile using the Create Feature Class tool.
    1. Open ArcToolbox and navigate to Data Management Tools > Feature Class > Create Feature Class.
    2. Specify the Feature Class Location and Feature Class Name for the output 2D shapefile.
    3. Specify the Geometry Type of the output 2D shapefile. The geometry type of the output shapefile must be the same as the 3D shapefile. For example, select POLYGON if the 3D shapefile contains polygon features.
    4. For Template Feature Class, select the existing 3D shapefile. This step pastes the feature over all attribute fields.
    5. Leave the Has M and Has Z parameters as DISABLED.
    6. For Coordinate System, import the spatial reference of the 3D shapefile.

      An image of the Create Feature Class dialog box.
       
    7. Click OK. A new 2D shapefile is created and added to Table Of Contents.
  3. In the Editor toolbar, click Start Editing to start editing on the new 2D shapefile.
  4. Select all features in the 3D shapefile by right-clicking the 3D layer in Table Of Contents > Selection > Select All.
  5. In the Standard toolbar, click Copy An image of the Copy button. to copy the selected features.
  6. Click Paste An image of the Paste button. to paste the copied features along with the attributes to the 2D shapefile. In the Paste dialog box, select the 2D shapefile as the Target, and click OK.

    An image of the Paste dialog box.
    Note:
    The Copy and Paste functions are also accessible through the Edit menu by clicking Edit > Copy or Edit > Paste.
    
    An image of the Edit menu.
    
  7. In the Editor toolbar, click Editor > Save Edits to save the edits. Click Editor > Stop Editing to stop the edit mode.

Convert 3D multipatch features

Use the Multipatch Footprint tool to convert 3D multipatch features to 2D features. The tool requires a 3D Analyst license. For more information, refer to: Multipatch Footprint.

Related Information