English
Continue in the app
Be The First To Get Support Updates
Want to know about the latest technical content and software updates?

How To: Identify deprecated Configurable Apps using a Python Script

Summary

At the ArcGIS Enterprise 11.0 release, a variety of deprecated configurable app templates have been removed from the Enterprise portal, which means that previously-configured apps, which may work fine at versions 10.9.1 and earlier, can no longer be opened after upgrading to ArcGIS Enterprise 11.0.

Procedure

This script assists with identifying applications in an Enterprise deployment that are subject to this deprecation, to allow application authors or administrators to migrate the applications to new templates, prior to an ArcGIS Enterprise Upgrade.

To run the script, replace your Portal URL and username in the first few lines, then run the script - the output is a list of all applications that will not function at ArcGIS Enterprise 11.0  and must be updated, retired or removed.

Related Information

Last Published: 7/5/2022

Article ID: 000027957