Error Message
When editing a submitted survey from ArcGIS Survey123, the following error is returned:
Error:
Editing is not possible because the record specified by the globalId parameter cannot be accessed.
Cause
- The ‘Only add new records’ option is enabled in ArcGIS Survey123.
- The ‘Editors can see all features’ option is disabled in ArcGIS Online.
- Incorrect global ID.
Solution or Workaround
Depending on the cause, use any of the options below to resolve the issue.
Disable the ‘Only add new records’ option in ArcGIS Survey123
- Log in to ArcGIS Survey123 and open the survey form.
- Click Collaborate > Share Survey.
- For What can submitters do?, select Add and update records (read access enabled) or Add, update, delete records (read access enabled).
- Click Save.
Enable the ‘Editors can see all features’ option in ArcGIS Online
- Log in to ArcGIS Online and click Content > My Content.
- Under Folders, browse for and click the folder with the survey form.
- Click the ‘<survey name>_form’ hosted feature layer.
- On the item details page, click Settings.
- Scroll to the Feature Layer (hosted, view) section, under What features can editors see?, select Editors can see all features.
- Click Save.
- Click Content > My Content.
- In the folder, click the ‘<survey name>_results’ hosted feature layer.
- Repeat Steps 4 to 6 to enable Editors can see all features for the hosted feature layer.
Use the correct global ID
Ensure the correct global ID is used in the survey’s URL parameter. Refer to ArcGIS Survey123: Edit in web app for more information on appending the global ID to the survey’s URL.