English
Continue in the app
Be The First To Get Support Updates
Want to know about the latest technical content and software updates?

Deprecation: ArcGIS Pro SDK .NET Framework 4.8 and Visual Studio 2017/2019 Support

Description

With the release of ArcGIS Pro 3.0, Microsoft’s .NET Framework 4.8 is no longer supported. ArcGIS Pro 3.0 introduces support for .NET 6.0, Microsoft's latest edition of .NET. Support for .NET 6.0 replaces support for .NET Framework 4.8. ArcGIS Pro 2.9 is the last release with .NET Framework 4.8.

The ArcGIS Pro 2.9 SDK is the last release with support for Visual Studio 2017 and 2019. The ArcGIS Pro 3.0 SDK introduces support for Visual Studio 2022, Microsoft's latest edition of its IDE. Pro 2.x versions will continue to be supported with Visual Studio 2017 and 2019, according to the Pro SDK Product Lifecycle.

Also, the Pro SDK ChromiumWebBrowser has been deprecated at Pro 2.9. Users must switch to the new WebViewBrowser control.

Recommendation

ArcGIS Pro 3.0 is a 'breaking change' release, meaning that the public APIs are subject to change. There are changes related to the move to .NET 6, as well as changes related to deletion of 'obsolete' classes and methods (for example, those items marked as obsolete in a previous release) and refactoring to improve consistency and quality of the public APIs.

Migrating 2.x add-ins to 3.0 is a 2-step process

  1. Convert your add-in Visual Studio project from Visual Studio 2017 or 2019, .NET Framework 4.x to Visual Studio 2022 and .NET 6.
    A conversion utility for this purpose will be provided as part of the Pro SDK at 3.0.
  2. Compile your (converted) add-in and fix any compilation errors (related to any breaking changes).

Esri will provide migration guide documentation to assist developers in migrating, including 'before and after' code snippets. Migration resources will be similar to those provided to support the changes from the past move from 1.x to 2.x. In addition, the Pro SDK includes many community samples that will all be converted at Pro 3.0, and serve as another set of 3.0 code examples for developers to reference.

In terms of compatibility, Pro 3.0 will follow the same pattern of add-in forward compatibility with Pro releases seen with Pro 1.x and 2.x add-in guidelines. Add-ins compiled with Pro 3.0 will work with all Pro 3.x releases, but not the earlier Pro 1.x and 2.x releases.

Customers with ArcGIS Pro 2.x add-ins that use third-party libraries must ensure that those libraries are supported with .NET 6 as they migrate their add-ins for use with Pro 3.0.

Related Links

Last Published: 4/14/2022

Article ID: 000027495