PROBLEM

Patches for the Portal for ArcGIS component of ArcGIS Enterprise freeze on Windows

Last Published: August 4, 2021

Description

On some Windows systems, installing patches for the Portal for ArcGIS component of ArcGIS Enterprise may result in a message saying "Installer is no longer responding". 

installer message

Cause

The Portal for ArcGIS component contains a large number of files and the install technology maintains a full list of all installed files. Maintaining that list during patches comes with significant overhead that can cause slower machines or VMs to take longer than the Windows Installer technology expects.  

Solution or Workaround

There are several mechanisms to avoid this problem or minimize its occurrence. 

  1. Use the /qn silent install option when possible. This avoids the problem entirely.  
     
    From an elevated command prompt run the following command:

    <patchname.msp> /qn

    For example:

    ArcGIS-109-S-ALPI-Patch.msp /qn
  1. If you receive the "Installer is no longer responding" warning during an interactive patch install, simply click Retry. On some systems, you may get the warning multiple times and can continue each time. The installer will ultimately finish. 

Consider temporarily disabling any processes that slow down file operations, such as anti-virus software and other security software. This reduces the chance of encountering this problem.  

Use the fastest possible storage for the install directory, such as SSD-backed storage. The faster seek times on SSD-backed storage significantly decrease the install time and reduce the chance of encountering this problem.

Article ID:000026175

Software:
  • Portal for ArcGIS

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