ERROR

Failed to create new feature(s). General Function Failure [database error has occurred.]

Last Published: February 18, 2022

Error Message

Attempts to create new features in a hosted feature layer in ArcGIS Pro fail, and return the following error message:

Error:   
Failed to create new feature(s). 
General function failure [Database error has occurred.]
Error message.

Cause

The relational data store in which the hosted feature layer is stored is set to read-only. In most cases, the relational data store is automatically set to read-only due to insufficient disk space.

Solution or Workaround

To resolve the error, change the relational data store setting from read-only to read-write mode using the following workflow.

  1. Open Windows Command Prompt as an administrator.
    1. Log in to the ArcGIS Data Store machine as an administrator.
    2. Right-click the Command Prompt app icon and select Run as administrator.
  2. Navigate to the ArcGIS Data Store tools directory using the following command line:
cd C:\Program Files\ArcGIS\DataStore\tools
  1. Ensure the relational data store is set to read-only. In the Command Prompt window, run the describedatastore utility.
C:\Program Files\ArcGIS\DataStore\tools>describedatastore

If the relational data store is in read-only mode, the prompt returns the following message:

Image showing the read-only mode setting.
  1. Change the relational data store setting from read-only to read-write. In the Command Prompt window, run the changedatastoremode utility. Refer to Portal for ArcGIS: changedatastoremode for more information.
C:\Program Files\ArcGIS\DataStore\tools>changedatastoremode readwrite --store relational --prompt no
Note:
In ArcGIS Data Store versions prior to version 10.8.1, the command line in Step 4 reads as follows:

C:\Program Files\ArcGIS\DataStore\tools>changedatastoremode readwrite 

When prompted with Do you wish to continue (Yes or No)?, type Yes, and press Enter.
  1. If the relational data store is automatically set to read-only due to low disk space, re-enable automatic backups. Run the updatebackupschedule utility. Insert the values for starttime and frequency in the command line. Refer to Portal for ArcGIS: updatebackupschedule for more information.
updatebackupschedule --starttime 23:00:00 --frequency 10
Update backup schedule.

Article ID:000022570

Software:
  • ArcGIS Pro
  • ArcGIS Data Store

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options