English

Problem: Upload content does not work in Google Chrome with Enterprise 10.7 and later on a Portal for ArcGIS machine

Description

When uploading files to Portal for ArcGIS Content from your computer the "Add Item" button may not work with Google Chrome. The Add Item button remains unresponsive and no error messages are observed, including the developer tools. The issue is specifically observed on the Portal machine and prevents the users from uploading any type of content. The same content can be uploaded successfully using Internet Explorer and from other machines to the same Portal.

Cause

The issue occurs due to the Local Group Policy settings, which disables the user from uploading content to Portal for ArcGIS through Google Chrome. The Attachment Manager under the Windows component is responsible for this behavior. 

Solution or Workaround

Use the following steps  to resolve this issue: 

  1.  Press the Windows Key + R and type gpedit.msc. Press Enter or click OK.
  2. In the left pane, navigate to User Configuration > Administrative Templates > Windows Components > Attachment Manager. In the right pane locate Do not preserve zone information in file attachments.
  3. Select Enabled and click Apply and OK to save changes.
  4. Click Inclusion list for low file types.
  5. Select Enabled and paste the following line in the Specify low risk extensions input field:
.avi;.bat;.cmd;.exe;.htm;.html;.lnk;.mpg;.mpeg;.mov;.mp3;.mp4;.mkv;.msi;.m3u;.rar;.reg;.txt;.vbs;.wav;.zip;.7z
  1.  Click on Apply and OK to save the changes.
  2. Close the Group Policy Editor and restart the PC.