PROBLEM

Clicking Approve for the Portal URL and APP ID in Web AppBuilder for ArcGIS (Developer Edition) fails with the error “no token found, redirect/ webappbuilder”

Last Published: May 5, 2021

Description

When launching Web AppBuilder for ArcGIS (Developer Edition), clicking the Approve button after entering the Portal URL and the App ID in the configuration page fails and redirects the user to the same configuration page. In the startup.bat command prompt, the following error is returned:

Error:
no token is found, redirect /webappbuilder

Cause

There are two possible causes for the issue:

  • The Portal URL was entered using http instead of https.
  • The domain name of the machine is not listed in the Allow Origins settings in the Portal for ArcGIS Organization settings. Due to the cross-origin domain restriction, Web AppBuilder for ArcGIS is unable to communicate with Portal for ArcGIS if the domain name is not listed in the settings.

Solution or Workaround

Use one of the following solutions according to the cause.
  • Use https instead of http for the Portal URL.
  • Include the domain machine name in the Allow Origins settings.
  1. Navigate to the Portal for ArcGIS Home page.
https://[domain name]/portal/home
  1. Click Organization > Edit Settings.
image.png
  1. Click Security.
image.png
  1. If there are any existing entries under Allow Origins, fill in the URL of the Web AppBuilder for Developers (up to the port number) in the box and click ADD DOMAIN.
image.png
  1. Click Save.

Article ID:000018879

Software:
  • ArcGIS Web AppBuilder
  • Portal for ArcGIS

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic