English

How To: Convert 3D point features in the XYZ file format to raster in ArcMap

Summary

The workflow provided describes how to convert 3D point features in the XYZ file format to raster using the 3D Analyst and Conversion tools in ArcMap.

Procedure

  1. Obtain the average point spacing value (Pt_Spacing) of the 3D point features using the Point File Information tool.
    1. In the ArcToolbox pane, click 3D Analyst Tools > Conversion > From File > Point File Information.
    2. In the Point File Information window, click the folder icon under the Browse for: Files section and navigate to the folder location of the 3D point data (.xyz). Select the 3D point data (.xyz) and click Open.
    3. In the Output Feature Class section, click the folder icon and specify the location for the output feature class. In the Output Feature Class window, specify a Name for the output and click Save.
    4. In the File Format section, select XYZ.
    5. Leave the other parameters at default, and click OK.
Point File Information tool
  1. In the Table Of Contents pane, under Layers, right-click the output and click Open Attribute Table. Copy the Pt_Spacing value.
Attribute table
  1. Convert the XYZ file to a feature class using the ASCII 3D To Feature Class tool.
    1. In the ArcToolbox pane, click 3D Analyst Tools > Conversion > From File > ASCII 3D To Feature Class.
    2. In the ASCII 3D To Feature Class window, click the folder icon under the Browse for: Files section, and navigate to the folder location of the point data (.xyz). Select the point data (.xyz) and click Open.
    3. In the Input File Format section, select XYZ.
    4. In the Output Feature Class section, click the folder icon and specify the folder location of the output feature class.
    5. In the Output Feature Class Type section, select MULTIPOINT.
    6. In the Average Point Spacing (optional) section, paste the value of the Pt_Spacing from the attribute table of the output in step 1(f).
    7. Leave the other parameters at default, and click OK.
ASCII 3D To Feature Class
  1. Convert the point feature class to raster using the Point to Raster tool.
    1. In the ArcToolbox pane, click Conversion Tools > To Raster > Point to Raster.
    2. In the Point to Raster window, in the Input Features section, select the point feature class (the output from step 2) and click Add.
    3. In the Output Raster Dataset section, navigate to the folder location of the output raster. In the Output Raster Dataset window, specify a Name for the output raster and click Save.
    4. Leave the other parameters at default, and click OK.
Point to Raster

Related Information