Error: 7581: The repair Request for authorization number ESUxxxxxxxxx (or EFLxxxxxxxxx) is denied
Error Message
The following error messages can be triggered for various reasons when authorizing online or offline.
"7248: The repair of the fulfillment is denied by the repair policy because max repairs exceeded [0942-80227155]"
"7581: The repair Request for authorization number EFLxxxxxxxxx is denied. Please contact ESRI Customer Service or your local ESRI distributor. [9295-87512761]"
Cause
One cause of the error message is if any changes have been made to the hardware.
When authorizing ArcGIS software via the authorization wizard, either online or offline, multiple identifiers are used authorizing on a specific machine.
The license validation should work as expected if there are only one or two upgrade components on the machine. However, if too many identifiers are changed, a 'repair' request is triggered.
Repairs, though uncommon, are available up to two times per year.
Solution or Workaround
The following steps provide different options for addressing this error message. The recommended procedure whenever possible is to deauthorize the software.
Online deauthorization
This is the removal of a software license that is tied to a particular machine. Deauthorization is permitted up to four times per year per license.
- Single-use deauthorization:
Click Start > All Programs > ArcGIS > ArcGIS Administrator > Desktop > Deauthorize (Deauthorize using the internet)
- Concurrent-use deauthorization:
Click Start > All Programs > ArcGIS > License Manager > License Server Administrator > Authorization > Deauthorize (Deauthorize using the internet)
Offline deauthorization
- Single-use offline deauthorization:
- Click Start > All Programs > ArcGIS > ArcGIS Administrator > Desktop > Deauthorize (Deauthorize at Esri website or by email)
- Select Save to create the deauthorization file and either e-mail it to authorize@esri.com or upload the file to https://service.esri.com/drm and follow the instructions to complete either option.
- Concurrent-use offline deauthorization:
- Click Start > All Programs > ArcGIS > License Manager > License Server Administrator > Authorization > Deauthorize (Deauthorize at Esri Web site or by e-mail)
- Select Save to create the deauthorization file and then either e-mail it to authorize@esri.com or upload the file to https://service.esri.com/drm and follow the instructions to complete either option.
Silent deauthorization for Single-use:
- Open a command prompt window.
- Change the path to C:\Program Files\Common Files\ArcGIS\bin
- Run the following command to deauthorize the software silently:
SoftwareAuthorization.exe -return ESUxxxxxxxxx /s< /pre>
Note: Enter the Single-use authorization number beginning with ESU. More than one authorization number can be strung together if there is more than one authorization number to deauthorize: SoftwareAuthorization.exe -return "ESUxxxxxxxxx,ESUxxxxxxxxx" /s
Silent deauthorization for Concurrent-use:
- Open a command prompt on the license server and change directories to C:\Program Files\ArcGIS\License10.x\bin
- Enter the following command:
SoftwareAuthorizationLS.exe -return EFLxxxxxxxxx
Note: Enter the Concurrent-use authorization number beginning with EFL. More than one authorization number can be strung together if there is more than one authorization number to deauthorize: SoftwareAuthorization.exe -return "EFLxxxxxxxxx,EFLxxxxxxxxx" /s
Delete the files within the Trust Storage
Note: Use this step only if unable to deauthorize the licenses.
Trusted storage location:
- Windows XP and Server 2003:
C:\Documents and Settings\All Users\Application Data\FLEXnet - Windows Vista, Server 2008 and Windows 7:
C:\ProgramData\FlexNet - Unix/Linux:
/usr/local/share/macrovision/storage
Procedure:
- Stop the ArcGIS License Manager service.
- Stop the Flexnet service.
- Delete the ArcGIS files within the trusted storage folder.
Related Information
- How To: Download and install Esri software from My Esri
- How To: Recover lost licenses from My Esri
- ArcGIS 10 Licensing Concepts and Stratergies:
- Authorizing your software
- What should be done with the *.dat file that is received from authorize@esri.com?
- Deauthorize ArcGIS Desktop and Engine Single Use licenses after uninstalling the software
- With licensing, what system parameters are referenced by the Trusted Storage licensing model?
Last Published: 9/19/2018
Article ID: 000011378
Software: ArcMap 10