PROBLEM

Unable to activate the GPS receiver and see the GPS position in ArcPad

Last Published: April 25, 2020

Description

Several minutes after connecting a GPS receiver to a device and activating the GPS in ArcPad, the current position is still not displayed on the screen either in the GPS Position Window or via the GPS cursor.

Cause

There are several possible causes:

1. The settings in the GPS page of the ArcPad Options dialog box are incorrect for the GPS receiver, or the protocol is incorrectly set in the Protocol page.

2. The batteries powering the GPS receiver are dead or low.

3. The cables connecting the GPS receiver to the device are incorrect or damaged.

4. The GPS receiver is not configured to output GPS data via a protocol that ArcPad supports (or at all).

5. The GPS receiver is damaged.

Solution or Workaround



  • Confirm that the settings are correct. There is a free FindGPS utility on ArcScripts that detects the GPS protocol and other settings and updates these settings in ArcPad if necessary.

    If this utility successfully detects the GPS and updates the settings, activate the GPS again and wait up to several minutes for a valid fix.
  • If the FindGPS utility fails to detect the GPS receiver, check the status of the receiver's batteries. If they are low, recharge or replace them and repeat step 1.
  • If the batteries have sufficient charge, check the cables connecting the GPS receiver to the device. Cable details for many GPS receivers can be found in "Using ArcPad". Contact the GPS device manufacturer for additional information if necessary.
  • Most GPS receivers can be configured via a Setup menu (handheld receivers like Garmin, Magellan, etc.) or configuration utility ("black box" type receivers like TeleType, Trimble, etc.). Make sure the GPS receiver is configured to output a protocol ArcPad supports (NMEA, TSIP, PLGR) and that the output is turned on. If NMEA is selected, be sure all NMEA sentences are selected for output.
  • If you still cannot activate the GPS receiver in ArcPad, the receiver may be damaged. Please follow the procedures for troubleshooting the GPS connection in "Using ArcPad". You may need to return your GPS receiver to the manufacturer for repair.

Article ID:000006013

Software:
  • ArcPad Prev

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