Description
In some instances, users are unable to find the ArcGIS Online tab either by clicking Customize Menu > Customize Mode > Commands Tab > ArcGIS Online, or by clicking the File menu.
Cause
This problem occurs if the ESRI.ArcGIS.MapCenter AddIn File present within the Bin folder of the desktop installation is either corrupted or deleted from the system.
Solution or Workaround
The following steps can be performed to recover the ArcGIS Online tab:
- Check that the AddIn file is named as ESRI.ArcGIS.MapCenter, and the type is set to Esri AddIn File, since in some cases the naming convention changes, which causes the issue:
ESRI.ArcGIS.MapCenter.esriaddin
- Attempt to Repair the application, in doing so, missing files can be added successfully.
- Provide the AddIn file from a working machine, and attempt to install the AddIn file onto the problematic machine. If this fails, directly copy and paste the AddIn file from the C:\Program Files (x86)\ArcGIS\Desktop10.8\bin\Addins folder.
To repair the application:
- Open the Windows Control Panel and select Programs and Features.
- In the Programs and Features window, right-click ArcGIS Desktop 10.8 (or the version in use), and click Uninstall/Change.
- Press Yes when prompted to allow the app to make changes to the device.
- In the ArcGIS Desktop 10.8 Setup dialog box, select Repair, and click Next.
- In the Ready to Repair the Program panel of the ArcGIS Desktop 10.8 Setup dialog box, click Install and follow the prompts.