Frequently asked question

Is it possible to create a dashboard in ArcGIS Dashboards without displaying the geometry of a feature layer?

Last Published: July 15, 2020

Answer

Yes, it is possible to create a dashboard in ArcGIS Dashboards without displaying the geometry of a feature layer. ArcGIS Dashboards can be used to display information or data for public users. However, in some instances, the geometry information is closed to public for security purposes. For example, point features representing locations of residential area to protect the privacy of the residents while displaying the attribute information such as maintenance and occupancy rate.

The steps to do this are as follows:

  1. In ArcGIS Online, navigate to the required hosted feature layer and the related table.
  2. Export the hosted feature layer and the related table as a file geodatabase to a folder and download both folders.
  3. In ArcMap or ArcGIS Pro, export the attribute table of the feature layer as a standalone table:
In ArcMap
  1. Make a folder connection to the downloaded file, and drag the feature layer to Table of Contents.
  2. Export the table as a standalone table.
In ArcGIS Pro
  1. Add the downloaded file to the project, and drag the feature layer to the Contents pane.
  2. Export the table as a standalone table.
  1. Use the Table To Table tool from Conversion Tools > To Geodatabase to export the related table.
In ArcMap
  1. Drag the related table to Table of Contents.
  2. Use the Table To Table tool to export the related table.
  3. In the Table To Table dialog box, for Input Rows, select the related table from the drop-down list.
  4. Specify Output Location with the file geodatabase used to store the standalone table as in Step3.
  5. Specify a name for Output Table.
  6. Leave the other parameters at default, and click OK to execute the tool.
Table To Table dialog box
 
In ArcGIS Pro
  1. Drag the related table to the Contents pane.
  2. Use the Table to Table (Conversion) tool to export the related table.
  3. In the Table To Table geoprocessing pane, for Input Rows, select the related table from the drop-down list.
  4. Specify Output Location with the file geodatabase used to store the standalone table as in Step3.
  5. Specify a name for Output Table.
  6. Select the desired output field for Field Map, and click Run to execute the tool.
Table To Table pane
  1. Create a relationship class between the standalone table created in Step 3 and the exported related table in Step 4.
In ArcMap
  1. Use the Create Relationship Class tool > Data Management Tools > Relationship Classes to create the relationship class.
  2. Select the standalone table created in Step 3 for Origin Table.
  3. Select the exported related table created in Step 4 for Destination Table.
  4. Specify a name for Output Relationship Class.
  5. Select the desired numerical relationship for Cardinality.
  6. Leave the other parameters at default, and click OK to execute the tool.
Create Relationship Class tool dialog box

In ArcGIS Pro
  1. Use the Create Relationship Class (Data Management) tool > Data Management Tools > Relationship Classes to create the relationship class.
  2. Select the standalone table created in Step 3 for Origin Table.
  3. Select the exported related table created in Step 4 for Destination Table.
  4. Specify a name for Output Relationship Class.
  5. Select the desired numerical relationship for Cardinality.
  6. Leave the other parameters at default, and click Run to execute the tool.
Create Relationship Class pane
  1. Convert the file geodatabase folder containing the relationship class to a zipped folder.
  2. Log in to ArcGIS Online, add the zipped folder and create an ArcGIS Dashboard:
    1. Open the standalone table and related table in a Map Viewer once the zipped folder is uploaded to ArcGIS Online.
Standalone table and related table
  1. Click Save > Save as, and fill in the required details to save the web map, and click Share.
  2. In the Share dialog box, check the check boxes of the groups to share the web map with, and click CREATE A WEB APP.
Share dialog box
  1. In the Create a New Web App dialog box, select ArcGIS Dashboards.
  1. In ArcGIS Dashboards, use the Details widget to display the attribute information from the relationship class created in Step 5.
    1. Click the Plus button drop-down list, and select Details when the dashboard is launched.
Plus drop-down list and Details widget
  1. In the Details tab, select the desired table to be displayed to public.
Selecting desired layer
  1. In Data, go to Data Options, make the necessary changes, and click Done.
Data tab
 
The image below shows the dashboard displaying the attribute information without displaying the geometry of the feature layer.
 
Final output of the dashboard

Article ID:000023435

Software:
  • ArcGIS Pro 2 x
  • ArcMap
  • ArcGIS Online

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic