ERROR

160333: The table was not found. Failed to execute <tool_name>

Last Published: May 20, 2022

Error Message

Attempts to add a new field to a feature class, including running geoprocessing tools involving field addition, fail and return the following error:

Error:
ERROR 160333: The table was not found. Failed to execute <tool_name>

Cause

The file geodatabase accessed when running the process is created from an older version of ArcGIS Desktop, preventing any changes on a new version of ArcGIS Pro.

Solution or Workaround

Run the Upgrade Geodatabase tool

The Upgrade Geodatabase tool upgrades the file geodatabase to match the current version of ArcGIS Pro used to run the file geodatabase. Refer to ArcGIS Pro: Upgrade Geodatabase (Data Management) for more information.

If the Upgrade Geodatabase tool fails, create a new file geodatabase and copy the feature datasets and feature class from the old file geodatabase

  1. On the Catalog pane, right-click the selected folder to store the new file geodatabase > New > File Geodatabase. Specify a unique name for the new file geodatabase.
  2. Locate the old file geodatabase and click the first feature dataset.
  3. Press the Shift key on the keyboard and select the last feature dataset. This selects all feature datasets available in the old file geodatabase.
  4. Right-click the selected feature datasets > Copy.
  5. Right-click the new file geodatabase > Paste.

Article ID:000027676

Software:
  • ArcGIS Pro 2 8 x
  • ArcGIS Pro 2 7 x
  • ArcGIS Pro 2 x

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options