問題

RDP 経由でリモートで操作しているときに、エラー 126 またはエラー 87 が発生して LoadLibrary を読み込めない

Last Published: May 3, 2024

説明

When working remotely to access ArcGIS Software, users rely on RDP (Remote Desktop Protocol) connections to use ArcGIS Desktop applications.
In some cases, the following errors may be encountered when launching ArcMap, ArcGIS Pro or other ArcGIS software:

Error:
LoadLibrary failed with error 126: The specified module could not be found.
or,
Error:
LoadLibrary failed with error 87: The parameter is incorrect.
 
Image of the error message

原因

When using RDP to connect to a remote machine, the error could be related to the RDP session itself. However, what may be occurring is a conflict between the video card specified by the RDP connection, and the one used by ArcMap on the remote machine. RDP is connecting by default to a built-in Intel video card, and not the video card used by ArcMap.

解決策または対処法

The solution is to disable the Intel video card, and restart the RDP session, forcing it to use the video card on the computer used by ArcGIS.

記事 ID:000023067

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