English

Problem: Unable to start CityEngine via remote desktop connection because of OpenGL error

Description

CityEngine does not launch when accessed from a remote desktop connection.

Cause

This occurs because CityEngine requires OpenGL 2.x to render graphics. Remote Desktop (RDP) does not support OpenGL on client machines higher than 1.1. Therefore when CityEngine is started by a remote desktop connection, the display is emulated with OpenGL 1.x causing it to display the following error.

Open GL Version
CityEngine requires at least OpenGL 2.0. Your current version (OpenGL 1.1.0, Microsoft Corporation GDI Generic) is not supported. Please update your drivers or contact support.

[O-Image] OpenGl Error

This occurs even when the physical machine that CityEngine is installed on has an acceptable version of OpenGL.

Solution or Workaround

There are two possible approaches to resolve this problem.

  • Start CityEngine on the machine prior to initiating a remote desktop connection
Or,
  • Create a batch file to disconnect the remote desktop session and automatically start City Engine on the computer

Example of the batch file:

#Use query session in cmd to determine session ID, usually 1
#User running RDP must be an admin.
#This disconnects RDP
tscon 1 /dest:console
#This starts CityEngine
start "CE" "C:\Program Files\ESRI\CityEngine\CityEngine.exe"

Connections can now be made through RDP and CityEngine starts.

Related Information

Last Published: 4/2/2020

Article ID: 000012119

Software: ArcGIS CityEngine 2015.2, 2015.1, 2015.0, 2014.1, 2014.0, 2013.1, 2012.1, 2011.2, 2011.1, 2010