PROBLEM

Services are not listed in the ArcGIS REST Services Directory

Last Published: June 8, 2023

Description

After upgrading ArcGIS Enterprise, services available in ArcGIS Server Manager and Portal for ArcGIS are not listed in the ArcGIS REST Services Directory in a federated environment, as shown in the image below:

Services are not listed in the ArcGIS Server REST Directory

Cause

  • The account accessing the services do not have to necessary permissions to the service folders.
  • The ArcGIS Server services folders are missing.

Solution or Workaround

Use one of the following workflows to resolve the issue:

Clear the browsing cache

Clear the web browser cache depending on the web browser used:

Check the service directories if the services are still present

Default ArcGIS Server services and created services are stored in the following directories:

  • Default services:
C:\arcgis\arcgisserver\config-store\services
  • Created Services:
C:\arcgis\arcgisserver\directories\arcgissystem\arcgisinput

Navigate to these folder to check if these folders are still present. If the folders are not present, consider doing the following:

If the services are still present in these folders, check if the service account accessing these services have the full control permissions to these folders. Refer to the Solution or Workaround section of Problem: Unable to access REST endpoint after changing the ArcGIS Server account for instructions.

Article ID: 000030479

Software:
  • ArcGIS Server
  • ArcGIS Enterprise 10 9 x
  • ArcGIS Enterprise 11 0
  • ArcGIS Enterprise 11 1

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options