ERROR

Error, try again

Last Published: February 16, 2023

Error Message

In ArcGIS Web AppBuilder, attempts to print a web map using the Print widget configured with the ArcGIS Enterprise print service fail with the following error message returned:

Error:
Error, try again
The error message returned when attempting to print a web map in ArcGIS Web AppBuilder

When hovering over the Error icon, the following error messages are returned:

Error:
Error executing tool. Export Web Map Task: Failed to create layer from service at <service URL>.
Failed to create layer from service at <service URL>.
Failed to execute (Export Web Map).
Failed to execute (Export Web Map Task).
The error message returned when hovering over the error icon

Cause

  • The PrintingTools geoprocessing service is stopped.
  • The firewall or antivirus software is preventing the service from starting by blocking back-end processes.
  • The browsing cache on the machine is not cleared.

Solution or Workaround

Use one of the methods below to resolve the issue.

Note:
When using an ArcGIS Server print service with services added by the members to the portal through HTTPS, additional configuration is required. Any machine that runs the print service must be configured to trust Certificate Authority (CA) signed certificates from the site providing the HTTPS services. Refer to ArcGIS Server: Import the CA root certificate into the Windows certificate store for more information.

Start the PrintingTools service if it is stopped

Navigate to ArcGIS Server Manager. Click Services > Manage Services > Utilities. Identify the PrintingTools service, and click the Start button.

Alternatively, restart the PrintingTools service if the service is running. Click the Stop button and click the Start button.

Configure the firewall settings

To allow a connection to ArcGIS Server, remove the firewall rule on the machine blocking the connection. Refer to How To: Configure ArcGIS Server for firewalls and NAT devices for more information.

Add exceptions to the antivirus software

Ensure the proper exceptions are in place for all the ArcGIS Enterprise directories. Refer to FAQ: Which ArcGIS Enterprise directories should be excluded for security or antivirus software? for more information on antivirus exceptions.

Clear the browsing cache

Clear the web browser cache depending on the web browser used:

Use a different browser

Use a different browser such as Google Chrome, Mozilla Firefox, or Microsoft Edge to log in to Portal for ArcGIS Map Viewer and print the desired web maps.

Article ID:000029627

Software:
  • ArcGIS Web AppBuilder
  • ArcGIS Server

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options