PROBLEM

Unable to remove items in ArcGIS Enterprise portal

Last Published: September 19, 2024

Description

Attempts to delete items in ArcGIS Enterprise portal fail, with the following error messages returned in the ArcGIS Server logs:

Error:
Unable to remove <item name>.<item extension> from server directory arcgisuploads. Failed to delete the item '<item ID>'. Configuration store error. File system '\\<ArcGIS Server installation location>\arcgisserver\config-store\uploads\<item ID>.json' remove failed. Delete item failed.
Error:
Failed to delete the item '<item ID>'. Configuration store error. File system '\\<ArcGIS Server installation location>\arcgissserver\config-store\uploads\<item ID>.json' remove failed. Delete item failed.
Error:
com.esri.arcgis.discovery.admin.AdminException: Configuration store error. File system '\\<ArcGIS Server installation location>\arcgisserver\config-store\uploads\<item ID>.json' remove failed. Delete item failed.

Cause

The portal index is corrupted, causing the index count for users to not match the store index count. This results in certain item's becoming detached, preventing them from being deleted.

Solution or Workaround

Perform a full reindex from the ArcGIS Portal Administrator Directory.

  1. Navigate to the Portal Administrator Directory as an administrator using the following URL:
https://<machine_name>.<domain_name>.com/webadaptor/portaladmin
  1. Navigate to System > Indexer > Reindex.
  2. For Mode, select Full from the drop-down list.
  3. For Format, select a response format from the drop-down list.
  4. Click Reindex.

Article ID: 000033526

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