ERROR

ArcGIS Survey123: Unable to publish the survey. Missing itemId

Last Published: September 24, 2024

Error Message

In ArcGIS Survey123, when an administrator assumes ownership of a survey or a newly-assigned survey owner attempts to publish an updated survey from the ArcGIS Survey123 web designer, the error message below is returned.

Error: 
Unable to publish the survey.
• -1: missing itemId / folderId / params arcgs
The error message

Cause

In ArcGIS Online, when survey items are transferred to a new owner, they are not placed in a dedicated folder for the items only. Instead, they are mixed with other items in the new owner’s existing folder. As a result, the new owner is unable to republish the form. A specific folder for the survey items must be created in the new owner’s Content page when changing the ownership of the survey.

The transferred survey items in the ne owner's existing folder

Solution or Workaround

In ArcGIS Online, create a new folder on the new owner’s Content page and move the survey items to the created folder. Refer to ArcGIS Online: Move multiple items for instructions.

Note: 
Specify a folder name similar to the survey title.

The image below shows the survey items in the created folder with the same name as the survey.

The survey items grouped in the same folder

Article ID:000033577

Software:
  • ArcGIS Online
  • ArcGIS Survey123 Website

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