问题

问题:Arctoolbox 对话框不显示在屏幕上

Last Published: April 25, 2020

描述

Arctoolbox 对话框不显示在屏幕上,但是看起来确实是显示在任务栏上。

:
本文中的内容适用于 ArcGIS 版本 8.x 和 9.x。 更高版本的 ArcGIS 可能包含不同的功能,对于菜单、命令和地理处理工具,可能具有不同的名称和位置。

原因

注册表中的窗口位置具有错误值或负值。

解决方案或解决方法

:
在执行以下任何程序之前,请连接第二台显示器,并通过扩展主显示屏在 Windows 中重新配置“显示设置”。 如果对话框在扩展显示区域中可见,请将其拖动到主显示器。 关闭并重新启动 ArcMap。

如果对话框仍然不可见,请尝试调整屏幕分辨率。 如果对话框可见,请将其拖动到主显示器。 关闭并重新启动 ArcMap。

更改对话框在注册表中的窗口位置。

警告: 
下面的说明涉及更改操作系统的重要组成部分。 建议您先备份操作系统及文件(包括注册表),然后再继续操作。 必要时,请咨询有资历的计算机系统专业人士。

在遵循这些说明进行操作时,Esri 无法保证非正确修改后的结果。因此,请谨慎使用并自行承担风险。
  1. 导航到开始 > 运行,键入 regedit,然后单击确定
  2. 导航至 HKEY_CURRENT_USER\Software\ESRI\ArcToolbox\Settings
  3. 双击 DlgWindowPos 并将数据值更改为 1,1,1,1。
  4. 单击确定
  5. 关闭“注册表编辑器”。
  6. 启动 ArcMap。尝试使用某些 Arctoolbox 工具;对话框现在应该在屏幕上。
:
在某些 10.x 版本的 ArcGIS Desktop 中发现了无法维护新注册表设置的问题。 这已被记录为 BUG-000115257。 

在这种情况下,提供了以下解决方法,但有一些注意事项。
警告:
以下解决方法可能会有意外结果。 重命名 Normal.mxt 模板可能会移除任何 ArcMap 自定义内容,例如已激活的工具栏、工具栏/面板定位以及文件夹/数据库连接。
  1. 在文件浏览器中 (例如 Windows 资源管理器),导航至 Templates 文件夹。 该路径会因使用版本的不同而有所差异,但遵循相同的 常规模式 ,如下所示:
    • C:\Users\\AppData\Roaming\Esri\Desktop10.6\ArcMap\Templates
  2. 重命名 Normal.mxt(例如 Normal.mxt.old)。
  3. 关闭并重新打开 ArcMap。

有关 Normal.mxt 文件的详细信息,请阅读 以下 Web 帮助文档, 保存自定义内容的基础知识

文章 ID:000008829

从 ArcGIS 专家处获得帮助

联系技术支持部门

下载 Esri 支持应用程序

转至下载选项

相关信息

发现关于本主题的更多内容