PROBLÈME

ArcGIS et réseau VPN : compréhension des erreurs de connexion, des délais d’expiration et des problèmes de performance lors du travail à distance

Last Published: June 10, 2020

Description

La méthode la plus fréquente d’utilisation à distance des logiciels Esri consiste à faire appel à un réseau VPN, bien que d’autres méthodes soient parfois employées, comme RDP (Remote Desktop Protocol). Lorsque vous utilisez des applications ArcGIS Desktop via une connexion VPN, il se peut que les performances connaissent une dégradation même si lors d’opérations relativement légères, comme la création d’une nouvelle classe d’entités et l’ajout de champs, l’ajout de règles attributaires ou la copie d’une petite classe d’entités d’une géodatabase à une autre.Vous pouvez ainsi rencontrer les problèmes suivants :

  • Lenteur à l’ouverture d’ArcMap et d’ArcGIS Pro
  • Entités manquantes lors du déplacement ou de l’application de zoom
  • Lenteur de l’exécution des outils de géotraitement
  • Lenteur du rafraîchissement des MXD
  • Lenteur des temps de réponse lors de l’ajout ou de la mise à jour des entités
  • Absence de réponse d’ArcMap lors de l’ajout d’une couche
  • Lenteur de l’affichage ou icône bleue qui tourne

D’autres problèmes peuvent également survenir :

  • Erreurs de connexion à la base de données
  • Erreurs du gestionnaire de licence
  • Latence à l’ouverture d’ArcGIS Server Manager
  • Pages vierges et autres erreurs de navigateur lors des tentatives d’accès aux pages d’accueil et aux cartes Web du portail ArcGIS Enterprise

Cet article décrit certains scénarios d’erreur courants et propose des méthodes permettant d’identifier la source de ces erreurs et de déterminer si elles proviennent du routeur, de la bande passante, de la configuration du VPN ou de problèmes de connexion à la base de données. L’isolement de ces problèmes peut aider à identifier les actions appropriées.

Remarque : Pour accéder au forum aux questions sur l’utilisation générale des technologies Esri à distance, comme l’installation, l’autorisation de licence, etc., reportez-vous au blog d’Esri Canada : How to access Esri technology while working from home.

Messages d’erreur
Outre la latence et les délais d’expiration et l’impossibilité générale à se connecter, de nombreux messages d’erreur sont renvoyés. La majorité de ces problèmes surviennent lors de l’utilisation d’applications ArcGIS connectées à un SGBDR hébergé sur un serveur réseau, par exemple, lorsque vous utilisez ArcMap ou Pro et que vous êtes connecté à une géodatabase d’entreprise. Des messages d’erreur supplémentaires indiquant la déconnexion du serveur de licence peuvent également être renvoyés.Vous trouverez ci-dessous quelques exemples de conditions et de messages d’erreur typiques :

Perte des connexions aux licences
Des messages similaires au message suivant peuvent être renvoyés :

Connexion aux licences perdue Connexion au serveur de licence perdue pour ArcGIS for Desktop Advanced (ARC/INFO). Tentative de reconnexion toutes les 120 secondes : tentative 1 sur 5...

Erreurs ArcGIS Desktop
Lorsque la connexion au VPN est intermittente, des indicateurs sont susceptibles d’apparaître dans l’interface utilisateur suggérant des erreurs de connexion aux données source, comme des points d’exclamation rouges en regard des fichiers de connexion à la géodatabase dans ArcGIS Pro.

Image de points d’exclamation rouge en regard des fichiers de connexion à la géodatabase dans ArcGIS Pro

Des points d’exclamation rouges peuvent également apparaître en regard des source de données de couches rompues dans des cartes, comme illustré ci-dessous.

Image de points d’exclamation en regard de sources de données de couches rompues dans des cartes

Vous pouvez aussi rencontrer les erreurs suivantes lors de l’enregistrement de mises à jour, la création de nouvelles entités, l’affichage ou l’ajout de nouvelles couches dans ArcMap :

Enregistrer les mises à jour Impossible d’enregistrer les mises à jour. Erreur de DBMS sous-jacente [ORA-03114: not connected to ORACLE] [SDE.DEFAULT]
Échec de la création d’entités. Erreur de DBMS sous-jacente [sde.DEFAULT]
Une ou plusieurs couches n’ont pas été dessinées U.S. Cities: Échec d’accès au serveur DBMS [ORA-03114: not connected to ORACLE::...]
Échec de l’ouverture Erreur lors de l’ouverture de la classe d’entités Erreur FDO : -2147155559 Échec d’accès au serveur DBMS[[Microsoft][Pilote ODBC Driver 17 pour SQL Server]Échec de la liaison de communication] [world01.sde.GBD_Items]

Erreurs générales de connexion à la base de données
De nombreuses erreurs sont susceptibles d’être renvoyées lors de tentatives de connexion à une base de données avec un VPN.Les niveaux de détail de ces messages peuvent varier. Voici quelques exemples :

Connexion Connexion au serveur de base de données pour récupérer la liste des bases de données impossible ; vérifiez le nom du serveur, le nom d’utilisateur et le mot de passe, puis réessayez. Erreur de DBMS sous-jacente...
Erreur Erreur de DBMS sous-jacente
Erreur de connexion La connexion à l’instance SGBD spécifiée a échoué. Une exception de connexion à une base de données s’est produite. Erreur FDO : -2147155559.

Cause

Les applications SIG consomment beaucoup de trafic réseau et les données SIG sont généralement partagées et stockées à partir d’un référentiel de données central. La plupart de ces problèmes de performance peuvent être liés à une bande passante insuffisante via les connexions VPN, comme lors de l’utilisation d’ArcMap ou d’ArcGIS Pro et d’une connexion à une géodatabase d’entreprise. L’accès à une géodatabase d’entreprise, que ce soit sur Microsoft SQL Server, Oracle ou un autre SGBDR via une connexion Internet, est toujours lent ; il existe cependant quelques solutions de contournement, comme indiqué ci-dessous.

Certaines opérations et certains processus font davantage appel au réseau que d’autres, selon les applications utilisées. L’application ArcMap est ainsi plus « bavarde » qu’ArcGIS Pro. De plus, si vous utilisez une nouvelle machine pour le travail à distance, il se peut qu’elle ne soit pas encore optimisée pour une utilisation avec ArcGIS.

Des délais d’expiration peuvent s’appliquer au serveur de licence lorsque le temps de réponse défini dans le serveur de licence est insuffisant. Il est possible de réinitialiser ce paramètre ou d’utiliser d’autres licences pour remédier à ce problème de délai d’expiration du serveur de licence.

Solution ou alternative

Recommandations générales

Remarque : Lorsque vous dépannez votre environnement pour déterminer la cause de l’erreur, il est fortement recommandé de noter les paramètres collectés ou les résultats des tests effectués, comme la bande passante, les connexions aux bases de données, la latence du réseau, etc., car ces informations peuvent aider les analystes techniques du support, qu’il s’agisse de votre fournisseur de services Internet, du service informatique de votre entreprise ou des services de support Esri.

Commencez avec les problèmes locaux susceptibles d’interférer avec les connexions à la plateforme ArcGIS. Vérifiez la bande passante fournie par votre fournisseur de services Internet. Si vous disposez de suffisamment de bande passante, commencez à dépanner la connexion VPN. Voici quelques recommandations générales :

  • Évitez d’avoir deux machines qui utilisent le VPN sur le même réseau Wifi.
  • Connectez-vous au routeur avec un câble LAN.
  • Redémarrez le routeur.
  • Vérifiez que votre profil utilisateur/système d’exploitation dispose des autorisations appropriées sur le logiciel de VPN de votre ordinateur.
  • Vérifiez qu’il n’existe aucune restriction en termes de communications via des pare-feux ou des applications d’anti-virus.
  • Exécutez un test de vitesse du réseau. Ces informations peuvent s’avérer utiles pour déterminer la bande passante disponible maximaleL’application Network Speed Test est également disponible dans Microsoft Store.
  • Utilisez RDP à la place du VPN.

Certains utilisateurs peuvent être équipés de nouveaux ordinateurs portables en vue du travail à distance et, si le problème ne semble pas venir du VPN ou de la base de données, il se peut que la machine nécessite une configuration supplémentaire pour une utilisation optimisée d’ArcGIS. Certaines recommandations d’optimisation des performances font l’objet de liens dans la section Informations associées ci-dessous.

Une fois ces éléments de base écartés, il est peut-être temps d’en parler avec votre service informatique interne. Quelques recommandations réseau spécifiques peuvent faciliter l’optimisation de la plateforme ArcGIS et il se peut que la conception de l’architecture système doive être réévaluée de telle sorte que les charges des pics de trafic répondent aux exigences de performances des utilisateurs, comme décrit dans la procédure de conception du système : Network Communications.

Perte des connexions aux licences
Les solutions possibles à cette erreur sont l’augmentation du délai d’expiration des licences, l’emprunt de licences qui permet d’éviter d’accéder constamment au serveur de licence, ou l’hébergement des licences ArcGIS Pro sur ArcGIS Online ; reportez-vous aux rubriques suivantes :

Erreurs ArcGIS Desktop

  • Il est possible d’améliorer les performances d’affichage dans ArcMap grâce à un caches d’entités côté bureau. Reportez-vous à la rubrique : Utilisation du cache d’entités.
  • Envisagez de migrer les processus vers ArcGIS Pro si cela est possible, car la consommation réseau est moins importante qu’avec ArcMap et les licences peuvent être hébergées dans ArcGIS Online.
  • Créez un réplica local de la géodatabase d’entreprise et synchronisez-le ultérieurement une fois que les mises à jour sont terminées.
  • Effacez le cache d’affichage. Le cache d’affichage facilite le déplacement et le zoom dans une carte existante, mais s’il est conservé au lieu d’être effacé d’une carte à une autre, il peut générer un important problème de performances. Dans ArcMap, cliquez sur Customize (Personnaliser) > ArcMap Options (Options ArcMap). Sur l’onglet Display Cache (Cache d’affichage), cliquez sur Clear Cache (Vider le cache).
  • Effacez l’historique de géotraitement en accédant à Geoprocessing (Géotraitement) > Geoprocessing Options (Options de géotraitement), et sous Results Management (Gestion des résultats), modifiez le paramètre sur Never Save (Ne jamais enregistrer) ou Keep results younger than 1 Day (Conserver les résultats postérieurs à 1 jour).

Erreurs générales de connexion à la base de données

  • Vérifiez que le logiciel client SGBDR est exécuté et configuré pour autoriser les connexions à distance.
  • Vérifiez que vous disposez de la maintenance et des correctifs à jour pour la base de données.
  • Exécutez des tâches planifiées pour effectuer la maintenance de la base de données pendant la nuit.

Les tests suivants peuvent vous aider à affiner la source du problème et aider le représentant du support technique à y remédier :
À partir de l’invite de commande :

  • Exécutez une commande Ping auprès du serveur de base de données, notez les temps de réponse et les éventuelles pertes de paquet.
  • Exécutez tracert.Combien y a-t-il de sauts ? Rencontrez-vous des expirations des demandes ?
Remarque : Lorsque vous exécutez des commandes, utilisez l’adresse IP du serveur à la place de HOSTNAME.
  • Si vous vous connectez à une base de données, exécutez la commande telnet auprès du serveur avec le numéro de port sur lequel la base de données écoute. Est-ce que la commande aboutit ?
  • Vérifiez les paramètres de pare-feu et/ou les stratégies de groupe ; il n’est toutefois pas conseillé de les désactiver, même dans le cadre de test.

ID d’article:000023346

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