français

Procédure : importer des tables de données XY dans ArcMap et convertir les données en un fichier de formes

Résumé

Les étapes ci-dessous fournissent des instructions permettant de formater des données XY en degrés décimaux à l’aide de Microsoft Excel et de convertir ces données en un fichier de formes ou une classe d’entités de géodatabase dans ArcMap.

ArcMap peut lire plusieurs formats de table pour afficher des données ponctuelles sous forme de thème d’événement.

Remarque :
Au niveau des versions 9.1 et antérieures, ArcMap peut lire les formats suivants : DBase III, DBase IV, .prn, .txt et .csv. Le cas échéant, les feuilles supplémentaires doivent être supprimées de ces formats sous Excel.
Remarque :
Au niveau des versions 9.2 et ultérieures, ArcMap peut lire les formats indiqués ci-dessus, ainsi que les feuilles de calcul .xls et .xlsx.

Procédure

  1. Pour vous vérifier qu’ArcMap lit correctement les données d’un fichier, utilisez Excel pour formater les colonnes contenant les valeurs de longitude (X ou abscisse) et de latitude (Y ou ordonnée) en tant que NUMBER, avec un minimum de 8 décimales.
    Le graphique ci-dessous montre la répartition des valeurs positives et négatives des coordonnées de longitude (X) et de latitude (Y) dans le monde.

    [O-Image] Decimal degree coordinates and signs
  2. La description du contenu de chaque colonne doit également être indiquée dans le fichier en sortie (colonnes ID, Longitude, Latitude, Description, etc.).
  3. Après avoir formaté le fichier, sélectionnez toutes les cellules des lignes et colonnes renseignées de la table et accédez à Fichier > Zone d’impression > Définir la zone d’impression ou à Mise en page > Zone d’impression > Définir la zone d’impression.
  4. Sélectionnez Fichier > Enregistrer sous et choisissez un format pris en charge proposé dans Excel. Cliquez sur Oui si Excel vous avertit qu’un formatage n’est pas pris en charge dans ce format de fichier.
  5. Quittez Excel. Cliquez sur Non lorsque Excel vous invite à enregistrer les changements.
    Remarque :
    Si les changements sont enregistrés, Excel convertit le fichier en classeur .xls ou .xlsx qui ne peut être utilisé que dans ArcMap versions 9.2 et ultérieures.
  6. Pour ajouter les données à partir d’un fichier .dbf, .csv, .txt ou .prn dans ArcMap, accédez à Tools (Outils) > Add XY Data (Ajouter des données XY) et sélectionnez le fichier. Dans la version 10.x, cliquez sur le bouton Add Data (Ajouter des données).
  7. Cliquez avec le bouton droit sur le nom de la table et sélectionnez Display XY Data (Afficher des données XY).
    Avertissement :
    Au niveau de la version 10.x, ArcMap applique le système de coordonnées du bloc de données aux données XY. Ce système de coordonnées risque d’être incorrect pour les données.
    Cliquez sur le bouton Edit (Mettre à jour) pour ouvrir la boîte de dialogue Spatial Reference Properties (Propriétés de référence spatiale). Cliquez sur le bouton Select (Sélectionner) afin de sélectionner un système de coordonnées pour les données.
    Remarque :
    Si un message d’avertissement relatif au champ manquant Object-ID s’affiche, vous pouvez l’ignorer en toute sécurité et cliquer sur OK. 
    [O-Image]
    
    Prenons l’exemple de données GPS qui sont le plus souvent collectées en degrés décimaux ou au format lat/long, qui est un système de coordonnées géographiques. Ouvrez ce répertoire. La plupart du temps, les données GPS sont collectées dans le datum WGS. Il convient donc d’ouvrir le dossier World et de sélectionner WGS_1984.prj.

    Si les données ont été collectées dans un autre datum, cliquez sur le lien intitulé « Systèmes de coordonnées géographiques et zones d’utilisation » dans la section Informations associées ci-dessous pour rechercher le datum approprié.
  8. Après avoir défini la projection, cliquez sur Add (Ajouter), Apply (Appliquer) et OK dans la boîte de dialogue Spatial Reference Properties (Propriétés de référence spatiale). Cliquez sur OK dans la boîte de dialogue Add XY Data (Ajouter des données XY). Les points sont dessinés en tant que thème Evénements dans ArcMap. Vérifiez que le thème Evénements s’aligne sur les autres données dans ArcMap.
    Remarque :
    Si les données ne s’alignent pas sur les données de référence, reportez-vous à l’article 7880 de la base de connaissance (précédemment l’article 29129), intitulé Identify the spatial reference, projection, or coordinate system of data (Identifier la référence spatiale, la projection ou le système de coordonnées des données).
  9. Pour convertir le thème événement en fichier de formes ou en classe d’entités de géodatabase, cliquez avec le bouton droit sur le nom du fichier et sélectionnez Data (Données) > Export Data (Exporter des données). Vous pouvez exporter les points vers une classe d’entités de géodatabase ou un fichier de formes.
  10. Les données peuvent également être à nouveau projetées dans le système de coordonnées du bloc de données ArcMap pendant ce processus. Accédez à l’onglet View (Afficher) > Data Frame Properties (Propriétés du bloc de données) > Coordinate System (Système de coordonnées) et sélectionnez la projection en sortie souhaitée pour les données en sortie. Pour effectuer la projection tout en exportant, cliquez avec le bouton droit sur le thème Events (Evénements), sélectionnez Data (Données) > Export Data (Exporter des données) et modifiez la sélection du bouton radio pour procéder à l’exportation vers le système de coordonnées du bloc de données. Les données en sortie s’affichent dans le système de coordonnées en sortie sélectionné.
  11. Pour projeter la couche d’événements dans un systèmes de coordonnées projetées à l’aide de l’outil Project (Projeter), suivez les instructions ci-dessous :
    a. Dans ArcMap, accédez à ArcCatalog > Toolboxes (Boîtes à outils) > System Toolboxes (Boîtes à outils système) > Data Management Tools (Outils de gestion des données) > Projections et sélectionnez Transformation > Project (Projeter) .
    b. Dans la boîte de dialogue Project (Projeter), renseignez les paramètres requis.

    Input Dataset or Feature Class (Jeu de données ou classe d’entités en entrée) : classe d’entités, couche d’entités ou jeu de classes d’entités à projeter.
    Input Coordinate System (Système de coordonnées en entrée) (facultatif) : système de coordonnées du jeu de classes d’entités ou de la classe d’entités en entrée.
    Output Coordinate System (Système de coordonnées en sortie) : système de coordonnées sur lequel les données en entrée doivent être projetées.
    Geographic Transformation (Transformation géographique) (facultatif) : à utiliser pour convertir des données entre deux systèmes de coordonnées géographiques ou datums.

    c. Cliquez sur OK.
    Remarque :
    Si ArcMap émet un avertissement indiquant que le système de coordonnées géographiques est différent de celui des autres données de la carte, accédez à l’onglet View (Afficher) > Data Frame Properties (Propriétés du bloc de données) > Coordinate System (Système de coordonnées) et cliquez sur le bouton Transformations pour vérifier que la transformation de datum correcte est employée pour la surface dans laquelle se trouvent les données.
    Remarque :
    Pour obtenir la liste des transformations géographiques (datum) et de leurs zones d’utilisation, cliquez sur le lien « Select the correct geographic (datum) transformation when projecting between datums (Sélectionner la transformation géographique (datum) correcte lors de la projection entre datums) ». Dans la section Informations associées de l’article, téléchargez la liste des transformations correspondant à la version d’ArcGIS Desktop installée sur votre ordinateur.

Informations associées