English

How To: Import XY data to ArcMap and convert the data to shapefile or feature class at ArcMap 10.1 and later versions

Summary

ArcMap (and ArcGIS Pro) cannot read data in degrees-minutes-seconds (DMS), and therefore this data must be converted into decimal degrees (DD) before importing.

The steps below give instructions for formatting XY coordinates, using Microsoft Excel, and converting these data to a shapefile or geodatabase feature class in ArcMap.

ArcMap can read several table formats, including DBase III; DBase IV; .prn, .txt, .csv, .xls, and xlsx.

Post-2003, Excel no longer generates files in DBase format.

Procedure

  1. To ensure ArcMap reads the data in the file correctly, use Excel to format the columns containing the Longitude (X, or Easting) and Latitude (Y, or Northing) values as NUMBER, with a minimum of 8 decimal places for decimal degree data.  For coordinates in meters or feet, 2 or 3 decimal places are sufficient. 
The graphic below shows the distribution of positive and negative values for longitude (X) and latitude (Y) coordinates worldwide.

[O-Image] Decimal degree coordinates and signs
Note:
Format the ID field as Number, with no decimal places.
Format Longitude and Latitude as Number, with at least 8 and up to 11 decimal places.
Format Elevation as Number, with up to 2 decimal places.
Format Description as text, with a length up to 255.
  1. Descriptions of the contents of each column are also required in the output file. Label columns ID, Longitude, Latitude, Elevation (if included), Description, etc.
  2. After formatting the fields in the table, select all the cells in populated rows and columns and navigate to File > Print Area > Set Print Area, or Page Layout > Print Area > Set Print Area. The exact location depends on the version of Excel being used.
  3. Navigate to File > Save As, and select a supported format from the choices available in Excel. Click Yes if Excel warns that certain formatting is not supported in this file format.
  4. Exit Excel. Click No when Excel prompts to save the changes.

The following steps are performed in ArcMap.

  1. To add the data from the formatted file to ArcMap, select the Add Data button and navigate to the folder where the table containing coordinates is saved on the computer, select the file and click Add.
  2. Right-click the table name in the Table of Contents and select Display XY Data.
    Warning:
    ArcMap applies the coordinate system of the Data Frame to the XY Data. This coordinate system is likely to be wrong for the data.
    Refer to the following Knowledge article: How To: Identify the spatial reference, projection, or coordinate system of data
    for assistance in identifying the type of coordinate system, and specific coordinate system for your coordinate values.
  3. Click the Edit button to open the Spatial Reference Properties dialog box. Click the Select button to select a coordinate system for the data.
    Note:
    If a warning message regarding the missing Object-ID field is displayed, it is safe to ignore it and click OK. 
    [O-Image]
    
    As an example, GPS data is most often collected in units of decimal degrees or lat/long, which is a geographic coordinate system. Open this directory. Most frequently, GPS data is collected on the WGS 1984 datum, so open the World folder, and select WGS_1984.prj.

    Best practice is to obtain the coordinate system information of the data from the data source.
  4. After defining the projection, click Add, Apply, and OK in the Spatial Reference Properties dialog box. Click OK in the Add XY Data dialog box. The points draw as an event theme in ArcMap. Verify that the Event theme aligns with the other data in ArcMap.
  5. The data can also be re-projected to the coordinate system of the ArcMap data frame during this process. Go to View > Data Frame Properties. Click the Coordinate System tab, and select the desired output projection for the new data. To project while exporting, right-click the Events theme, select Data > Export Data, and change the radio button to export to the coordinate system of the data frame. The output data is created in the selected output coordinate system.
Note:
If ArcMap warns of a "different geographic coordinate system than other data in the map", navigate to
View > Data Frame Properties > Coordinate System tab.  Click the Transformations button, and select the correct datum
transformation to transform between the datums in the ArcMap Data Frame for the area where the data is located.
For a list of geographic (datum) transformations, areas of use, and accuracy, see the following article:
HowTo: Select the correct geographic (datum) transformation when projecting between datums.
Under the Related Information section of the article, download the list of transformations for
the version of ArcGIS Desktop installed on the computer.
Note:
If the input coordinates are in Degrees-Minutes-Seconds (DMS), the Convert Coordinate Notation tool, located in
ArcToolbox > Data Management Tools > Projections and Transformations, can be used to convert those
values to Decimal Degrees (DD).  Refer to the Tool Help for instructions to format the input data.

Related Information