ERREUR

Impossible de restituer la licence empruntée dans ArcGIS Pro

Last Published: February 21, 2024

Message d’erreur

Lorsque vous tentez de restituer une licence flottante empruntée dans ArcGIS Pro, le processus échoue et le message d’erreur suivant est renvoyé :

Error:
Failed to return borrowed license.
Impossible de restituer la licence empruntée

Cause

  • Problèmes de réseau. Dans certains cas, ArcGIS License Manager peut être hébergé sur une machine virtuelle, tandis que la machine exécutant ArcGIS Pro réside sur un réseau local. Si ces machines se trouvent sur des réseaux différents, des problèmes de connectivité peuvent survenir.
  • L’utilisateur ne dispose pas des privilèges d’administration nécessaires pour restituer la licence empruntée.
  • ArcGIS License Manager n’est pas accessible à travers le pare-feu.
  • Le fichier de licence est endommagé.

Solution ou alternative

Selon la cause, les solutions ci-dessous s’appliquent.

Note:
For the workarounds provided, ensure the 'Authorize ArcGIS Pro to work offline' check box is unchecked on the Licensing page of ArcGIS Pro.

Connecter la machine au même réseau qu’ArcGIS License Manager

Connectez la machine au même réseau qu’ArcGIS License Manager pour garantir une connectivité réseau cohérente. Des problèmes de connectivité peuvent survenir en raison de connexions Internet faibles ou instables. Par exemple, envisagez de vous connecter au même VPN qu’ArcGIS License Manager.

Note:
This issue also occurs when the License Manager Server's IP Address and the Host name are mismatched with the IP address and Host name in the 'hosts' file. Refer to Bug: ArcGIS Desktop resolves only the hostname (and not the fully qualified domain name) when returning a borrowed license for additional information.

Utiliser un compte d’administrateur pour restituer la licence empruntée

Utilisez un compte disposant de privilèges d’administration pour vous connecter à ArcGIS Pro et restituer la licence empruntée. Reportez-vous à la rubrique Portal for ArcGIS : Privilèges d’administration pour plus d’informations.

Configurer ArcGIS License Manager pour qu’il soit accessible à travers le pare-feu

Note:
The following workflow may require some assistance from the organization's IT department.

Configurez ArcGIS License Manager pour qu’il soit accessible à travers le pare-feu. Reportez-vous au Guide du gestionnaire de licences : Configurer ArcGIS License Manager pour qu’il fonctionne à travers un pare-feu pour obtenir des instructions.

Effacer le stockage approuvé, récupérer et autoriser la licence

  1. Effacez le stockage approuvé sur la machine. Reportez-vous à la rubrique Procédure : effacer ou supprimer le stockage approuvé des licences flottantes et fixes pour obtenir des instructions.
  2. Récupérez le fichier de licence depuis My Esri. Reportez-vous à la rubrique Procédure : récupérer les licences perdues depuis My Esri pour obtenir des instructions.
  3. Autorisez une licence de remplacement sur ArcGIS License Manager. Reportez-vous à la rubrique ArcGIS Pro : Autoriser des licences flottantes pour obtenir des instructions et plus d’informations.
  4. Configurez ArcGIS Pro afin d’utiliser la licence autorisée. Reportez-vous à la rubrique ArcGIS Pro : Sélectionner une licence flottante comme type de licence pour obtenir des instructions et plus d’informations.

ID d’article: 000030962

Obtenez de l'aide avec l'IA

Résolvez rapidement votre problème avec le chatbot Esri Support AI.

Commencez à discuter maintenant

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Commencez à discuter maintenant

Accéder aux options de téléchargement