BUG

ArcGIS Desktop resolves only the hostname (and not the fully qualified domain name) when returning a borrowed license

Last Published: March 30, 2023

Description

ArcGIS Desktop resolves only the hostname (and not the fully qualified domain name) when returning a borrowed license. This prevents returns on networks, for example sub-domains, where a fully qualified domain name (FQDN) is required to reach the license manager.

In a Concurrent Use licensing model, all ArcGIS licenses are hosted on an ArcGIS License Manager server. For a client machine to consume licenses, it must connect to the license server via the use of a hostname, a fully qualified domain name (FQDN), or the IP Address. The client application such as the ArcGIS Administrator for ArcGIS Desktop or ArcGIS Pro can also borrow the licenses to be used offline. In doing so, the client application stores the information in a trusted storage. One component of the information stored is the hostname of the machine. When returning the borrowed licenses, the application looks for the hostname of the license server. If the license server is not reachable by the hostname, the return attempt fails. This occurs in most networks where the license server is only accessible by the FQDN, for example a license server hosted in the cloud.

Cause

Steps to Reproduce

  1. Install ArcGIS License Manager 2020.0 on a supported operating system in Amazon Web Services EC2. Authorize Concurrent Use ArcGIS Pro and/or ArcGIS Desktop licenses. 
  2. Configure the license manager to be accessible through the firewall. Refer to the web help below for the specific workflow: ArcGIS Desktop: Configure ArcGIS License Manager to work through a firewall.
  3. From ArcGIS Pro or ArcGIS Administrator, enter the external FQDN or IP Address to point to the license server, for example, "licenseserver.mysubdomain.domain.com."
  4. Borrow an available core* license. Once the borrow function is complete, take the system offline and start the application.
    *A core license which starts the application, for example Desktop or Pro Advanced/Standard/Basic.
  5. Connect back to the network and attempt to return the borrowed license. It eventually fails with the following message:
"Failed to return borrowed license."
Image of the Failed to return borrowed license error message
Note:
This issue does not affect the Named User licensing model.

Workaround

  1. Add the License Manager Server's IP Address and Correct the Host name to the "hosts" file in: C:\Windows\System32\drivers\etc\hosts on the client side.
  2. After correcting the host name and IP address, borrowed licenses can be successfully returned to the License Server.

Article ID:000022982

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