ERREUR

Erreur, veuillez réessayer

Last Published: February 16, 2023

Message d’erreur

Dans ArcGIS Web AppBuilder, les tentatives d’impression d’une carte Web à l’aide du widget Print (Imprimer) configuré avec le service d’impression ArcGIS Enterprise échouent et le message d’erreur suivant s’affiche :

Error:
Error, try again
Message d’erreur affiché lors de la tentative d’impression d’une carte Web dans ArcGIS Web AppBuilder

Lorsque vous passez la souris sur l’icône d’erreur, les messages d’erreur suivants s’affichent :

Error:
Error executing tool. Export Web Map Task: Failed to create layer from service at <service URL>.
Failed to create layer from service at <service URL>.
Failed to execute (Export Web Map).
Failed to execute (Export Web Map Task).
Message d’erreur affiché lors du survol de l’icône d’erreur

Cause

  • Le service de géotraitement PrintingTools est arrêté.
  • Le pare-feu ou le logiciel antivirus empêche le service de démarrer en bloquant les processus en arrière-plan.
  • Le cache de navigation sur la machine n’est pas vidé.

Solution ou alternative

Utilisez l’une des méthodes décrites ci-après pour résoudre le problème.

Note:
When using an ArcGIS Server print service with services added by the members to the portal through HTTPS, additional configuration is required. Any machine that runs the print service must be configured to trust Certificate Authority (CA) signed certificates from the site providing the HTTPS services. Refer to ArcGIS Server: Import the CA root certificate into the Windows certificate store for more information.

Démarrez le service PrintingTools s’il est arrêté

Accédez à ArcGIS Server Manager. Cliquez sur Services > Manage Services (Gérer les services) > Utilities (Utilitaires). Identifiez le service PrintingTools et cliquez sur le bouton Start (Démarrer).

Vous pouvez également redémarrer le service PrintingTools s’il est en cours d’exécution. Cliquez sur le bouton Stop (Arrêter), puis sur le bouton Start (Démarrer).

Configurer les paramètres du pare-feu

Pour autoriser une connexion à ArcGIS Server, supprimez la règle de pare-feu sur la machine bloquant la connexion. Pour plus d’informations, reportez-vous à la rubriqueProcédure : configurer ArcGIS Server pour les pare-feu et les appareils NAT .

Ajouter des exceptions au logiciel antivirus

Assurez-vous que les exceptions appropriées sont en place pour tous les répertoires ArcGIS Enterprise. Pour plus d’informations sur les exceptions antivirus, reportez-vous à la rubrique FAQ : quels répertoires ArcGIS Enterprise faut-il exclure pour des programmes de sécurité ou des logiciels antivirus ?

Vider le cache de navigation

Videz le cache en fonction du navigateur Web utilisé :

Utiliser un autre navigateur

Utilisez un autre navigateur tel que Google Chrome, Mozilla Firefox ou Microsoft Edge pour vous connecter à Portal for ArcGIS Map Viewer et imprimer les cartes Web souhaitées.

ID d’article: 000029627

Recevoir des notifications et trouver des solutions liées à de nouvelles questions ou à des problèmes connus

Recevez des réponses synthétisées et des solutions en vidéo de notre nouvel agent conversationnel (IA).

Télécharger l’application Esri Support

Obtenir de l’aide auprès des experts ArcGIS

Contacter le support technique

Télécharger l’application Esri Support

Accéder aux options de téléchargement