PROBLEMA

ArcGIS y VPN: Información sobre los errores de conexión, los tiempos de espera y los problemas de rendimiento cuando se trabaja de forma remota

Last Published: June 10, 2020

Descripción

El método más común para utilizar el software de Esri de forma remota es a través de VPN, aunque a veces se utilizan otros métodos, como el Protocolo de escritorio remoto (RDP). Al trabajar con aplicaciones de ArcGIS Desktop a través de una conexión VPN, pueden producirse degradaciones de rendimiento incluso cuando se realizan operaciones relativamente ligeras, como crear una nueva clase de entidad y agregar campos, agregar reglas de atributos o copiar una pequeña clase de entidad de una geodatabase en otra.Estos problemas pueden incluir:

  • Apertura lenta de ArcMap y ArcGIS Pro
  • Entidades ausentes al realizar un desplazamiento panorámico o hacer zoom
  • Finalización lenta de las herramientas de geoprocesamiento
  • Repetición de dibujo lenta de los MXD
  • Tiempos de respuesta largos al agregar o editar entidades
  • ArcMap no responde al agregar una capa
  • Tiempos de dibujo lentos o un icono azul giratorio

Pueden producirse otros problemas, incluidos

  • Errores de conexión de base de datos
  • Errores de License Manager
  • Latencia al abrir ArcGIS Server Manager
  • Páginas en blanco y otros errores del navegador al intentar acceder a las páginas de inicio y los mapas web del portal de ArcGIS Enterprise

Este artículo describe algunos escenarios de error comunes y proporciona algunos métodos para ayudar a identificar el origen de estos errores y a reconocer si provienen de problemas de conexión de base de datos, del router, del ancho de banda o de la configuración de VPN. El aislamiento de estos problemas puede ayudar a identificar las acciones adecuadas.

Nota: Para ver una lista de preguntas frecuentes sobre el uso general de la tecnología de Esri de forma remota, como la instalación, la autorización de licencias, etc., consulte el blog de Esri Canadá: Cómo acceder a la tecnología de Esri mientras trabaja desde casa.

Mensajes de error
Además de la latencia y los tiempos de espera y la incapacidad general para conectarse, se devuelven muchos mensajes de error. La mayoría de estos problemas ocurren al trabajar en aplicaciones de ArcGIS que están conectadas a un RDBMS alojado en un servidor de red, como al trabajar en ArcMap o Pro y conectarse a una geodatabase corporativa. Se pueden devolver mensajes de error adicionales que indican que el servidor de licencias se desconecta.Algunos ejemplos de condiciones de error y mensajes típicos son los siguientes:

Conexiones de licencia perdidas
Es posible que se devuelvan mensajes como los siguientes:

Conexión de licencia perdida Conexión perdida con el servidor de licencias para ArcGIS for Desktop Advanced (ARC/INFO). Intentando volver a conectar cada 120 segundos: intento 1 de 5...

Errores de ArcGIS Desktop
Cuando la conexión VPN es intermitente, pueden aparecer indicadores en la interfaz de usuario que sugieren errores de conexión con los datos de origen, como signos de exclamación rojos junto a los archivos de conexión de geodatabase en ArcGIS Pro.

Imagen de signos de exclamación rojos junto a los archivos de conexión de geodatabase en ArcGIS Pro

O fuentes de datos de capa dañadas en documentos de mapa con signos de exclamación rojos junto a ellas, como se muestra a continuación.

Imagen de fuentes de datos de capa dañadas en documentos de mapa con signos de exclamación rojos junto a ellas

Además, se devuelven errores como los siguientes al guardar ediciones, crear nuevas entidades, dibujar o agregar nuevas capas en ArcMap:

Guardar cambios No se pueden guardar las ediciones. Error subyacente de DBMS [ORA-03114: no conectado a ORACLE] [SDE.DEFAULT]
Error al crear nuevas entidades. Error subyacente de DBMS [sde.DEFAULT]
No se pudieron dibujar una o más capas. Ciudades de EE. UU.: Error al acceder al servidor DBMS [ORA-03114: no conectado a ORACLE::...]
Error al abrir Error al abrir la clase de entidad Error FDO: -2147155559 Error al acceder al servidor DBMS[[Microsoft][ODBC Driver 17 for SQL Server]Communication link failure] [world01.sde.GBD_Items]

Errores de conexión general de base de datos
Es posible que se devuelvan numerosos errores al intentar conectarse a una base de datos con VPN.Estos mensajes pueden tener distintos niveles de detalle. Algunos ejemplos son los siguientes:

Conexión No es posible conectar al servidor de la base de datos para recuperar la lista de bases de datos. Verifique su nombre de servidor, su nombre de usuario y la contraseña e inténtelo de nuevo. Error subyacente de DBMS...
Error Error subyacente de DBMS
Error de conexión Error al conectarse a la instancia de DBMS especificada. Se ha producido una excepción de error de conexión de base de datos. Error FDO: -2147155559.

Causa

Las aplicaciones SIG son grandes usuarios de tráfico de red y los datos SIG se comparten y almacenan normalmente desde un repositorio de datos central. La mayoría de estos problemas de rendimiento se pueden asociar a un ancho de banda insuficiente a través de conexiones VPN, como cuando se trabaja en ArcMap o ArcGIS Pro y se conecta a una geodatabase corporativa. Acceder a una geodatabase corporativa, ya sea en Microsoft SQL Server, Oracle u otro RDBMS a través de una conexión a Internet siempre será lento, pero algunas alternativas se proporcionan a continuación.

Algunas operaciones y flujos de trabajo requieren más intensidad de red que otras, dependiendo de las aplicaciones utilizadas, por ejemplo, ArcMap es más "comunicativa" que ArcGIS Pro. No obstante, si está utilizando un nuevo equipo para el trabajo remoto, es posible que todavía no esté optimizado para su uso con ArcGIS.

Los tiempos de espera del servidor de licencias pueden ocurrir cuando no hay suficiente tiempo de respuesta establecido en el License Manager; esto se puede restablecer y el uso alternativo de licencias también puede reducir el tiempo de espera del servidor de licencias. 

Solución o solución alternativa

Recomendaciones generales

Nota: Aunque solucione problemas de su entorno para determinar la causa, se recomienda encarecidamente tomar nota de cualquier configuración recopilada o los resultados de cualquier prueba realizada, como el ancho de banda, las conexiones de base de datos, latencia de red, etc., ya que esta información podría ayudar a los analistas técnicos en el canal de soporte que busque, ya sea su ISP, el departamento de TI corporativo, o los servicios de Soporte técnico de Esri.

Comience con los problemas locales que puedan interferir con las conexiones a la plataforma ArcGIS. Tenga en cuenta el ancho de banda proporcionado por su ISP. Si dispone de un ancho de banda suficiente, empiece a solucionar los problemas de la conexión VPN. Algunas recomendaciones generales son:

  • Evitar tener dos equipos utilizando VPN en la misma wifi
  • Utilizar una conexión de cable LAN al router
  • Reiniciar el router
  • Asegurarse de disponer de los permisos adecuados en el SO/perfil de usuario para el software VPN en el PC
  • Asegurarse de que no haya restricciones en cuanto a las comunicaciones a través de firewalls o aplicaciones antivirus
  • Ejecutar una prueba de velocidad de red. Esta información puede ser útil para determinar el ancho de banda máximo disponible.La aplicación de prueba de velocidad de red también está disponible desde la tienda de Microsoft.
  • Usar RDP en lugar de VPN

Es posible que algunos usuarios hayan obtenido nuevos equipos portátiles para el trabajo remoto y, si no se sospecha de una base de datos o VPN, puede que el equipo requiera cierta configuración para optimizar el uso de ArcGIS. En la sección Información relacionada que aparece a continuación, se presentan algunas recomendaciones para el ajuste del rendimiento.

Una vez descartados estos elementos básicos, puede que sea el momento de hablar con su departamento de TI interno. Existen recomendaciones de red específicas que pueden ayudar a optimizar la plataforma ArcGIS y es posible que deba reevaluar el diseño de arquitectura del sistema para garantizar que las cargas máximas de tráfico puedan satisfacer los requisitos de rendimiento del usuario, como se describe en el Proceso de diseño del sistema: Comunicaciones de red.

Conexiones de licencia perdidas
Las posibles soluciones para este error incluyen aumentar el tiempo de espera de la licencia, tomar prestadas licencias en lugar de ir continuamente al servidor de licencias o alojar licencias de ArcGIS Pro en ArcGIS Online; consulte:

Errores de ArcGIS Desktop

  • El rendimiento del dibujo en ArcMap se puede mejorar utilizando una caché de entidad en el lado de escritorio. Consulte: Trabajar con la caché de la entidad
  • Considere la posibilidad de migrar flujos de trabajo a ArcGIS Pro si es posible: requiere menos intensidad de red que ArcMap y las licencias se pueden alojar en ArcGIS Online.
  • Cree una réplica local de la geodatabase corporativa y sincronice la réplica más tarde, una vez finalizadas las ediciones.
  • Borre la caché de visualización. La caché de visualización facilita el desplazamiento panorámico y el zoom en el mapa existente, pero si la caché se conserva en lugar de borrarse de un mapa al siguiente, el impacto en el rendimiento puede ser considerable. En ArcMap, haga clic en Personalizar > Opciones de ArcMap. En la pestaña Caché de visualización, haga clic en Borrar la caché.
  • Borre el historial de geoprocesamiento: vaya a Geoprocesamiento > Opciones de geoprocesamiento y en Gestión de resultados, cambie el ajuste a No guardar nunca o a Guardar resultados de menos de 1 día.

Errores de conexión general de base de datos

  • Asegúrese de que el software cliente de RDBMS se esté ejecutando y esté configurado para permitir conexiones remotas.
  • Asegúrese de estar al día en el mantenimiento y los parches de la base de datos.
  • Ejecute tareas programadas para realizar el mantenimiento de la base de datos por la noche.

Las siguientes pruebas pueden ayudar a reducir la causa del problema y ayudar a su representante de soporte técnico a resolver los problemas:
Desde el símbolo del sistema:

  • Realice un Ping al servidor de la base de datos, anote los tiempos de respuesta y cualquier pérdida de paquete.
  • Ejecute tracert. ¿Cuántos saltos? ¿Existe algún tiempo de espera de solicitud?
Nota: Al ejecutar comandos, utilice la dirección IP del servidor en lugar de HOSTNAME.
  • Si se conecta a una base de datos, establezca una conexión telnet al servidor con el número de puerto que está escuchando la base de datos. ¿Está claro?
  • Revise la configuración del firewall o las políticas de grupo; sin embargo, no se recomienda deshabilitarlas, ni siquiera para realizar pruebas.

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