PROBLEMA

ArcGIS Pro se bloquea al agregar una conexión de base de datos

Last Published: April 16, 2021

Descripción

En ArcGIS Pro, agregar una conexión de base de datos desde un cliente de base de datos de ArcGIS a ArcGIS Pro permite analizar, visualizar, administrar, filtrar y compartir los datos actuales en la base de datos o agregar datos desde otras fuentes. En algunos casos, al agregar una conexión de base de datos a un proyecto, ArcGIS Pro se inmoviliza.

Causa

A veces, un tiempo de uso intensivo o trabajar con varios mapas al mismo tiempo provocan que ArcGIS Pro se bloquee o deje de funcionar.

Solución o solución alternativa

Realice un restablecimiento parcial cambiando el nombre de la carpeta de aplicación de Esri en el Explorador de archivos de Microsoft y editando la clave de registros de Microsoft Windows. Siga los pasos a continuación:

Advertencia: Editar el registro de Windows requiere privilegios de administrador en el equipo y solo se debe hacer como último recurso. Realice una copia de seguridad del registro o el equipo antes de continuar con los pasos que se indican a continuación. Si es necesario, consulte a un profesional en sistemas informáticos cualificado. Esri rechaza toda responsabilidad por modificaciones incorrectas al seguir estas instrucciones. Se recomienda precaución por parte del usuario.
  1. Abra el Explorador de archivos y vaya a la carpeta Roaming.
C:\Usuarios\<YourUsername>\AppData\Roaming
Nota: La carpeta AppData de Windows está oculta de manera predeterminada. Para mostrar carpetas ocultas, consulte Soporte técnico de Microsoft Windows: Mostrar archivos ocultos.
  1. Haga clic con el botón derecho en la carpeta de aplicación ESRI y haga clic en Cambiar nombre.
Ubicación de la carpeta AppData de Esri en el Explorador de Windows
  1. Cambie el nombre de la carpeta a ESRI_anterior.
  2. Abra el Editor del Registro en Windows 10. Para ello, consulte Soporte técnico de Microsoft Windows: Cómo abrir el Editor del Registro en Windows 10.
  3. En la ventana del Editor del Registro, expanda la siguiente carpeta de clave de registro en el árbol de carpetas.
Computer\HKEY_CURRENT_USER\Software\ESRI\ArcGISPro\Licensing
  1. En el panel de clave Licenciamiento de ArcGIS Pro, asegúrese de que el valor de clave ARCPROWORKOFFLINE sea FALSE.
Ubicación de la carpeta de la clave de registro de Esri en el Editor del Registro de Microsoft Windows
Nota: Si el valor de clave ARCPROWORKOFFLINE es TRUE, inicie sesión en la aplicación ArcGIS Pro y desactive la casilla de verificación Autorizar ArcGIS Pro para funcionar sin conexión en la página Licenciamiento. Continúe en el paso 7. La ventana Licenciamiento de ArcGIS Pro
  1. Haga clic con el botón derecho en la carpeta de clave de registro ESRI y haga clic en Cambiar nombre.
  2. Cambie el nombre de la carpeta de clave de registro a ESRI_anterior.
Cambiar nombre a la carpeta de la clave de registro de Esri en el Editor del Registro de Microsoft Windows
  1. Reinicie el equipo.

Se crea una nueva carpeta Esri al iniciar ArcGIS Pro.

Id. de artículo:000024975

Obtener ayuda de expertos en ArcGIS

Contactar con soporte técnico

Descargar la aplicación de soporte de Esri

Ir a las opciones de descarga

Información relacionada

Descubrir más sobre este tema