ERROR

Error, inténtelo de nuevo

Last Published: February 16, 2023

Mensaje de error

En ArcGIS Web AppBuilder, los intentos de imprimir un mapa web utilizando el Widget Imprimir configurado con el servicio de impresión de ArcGIS Enterprise fallan y se devuelve el siguiente mensaje de error:

Error:
Error, try again
El mensaje de error devuelto al intentar imprimir un mapa web en ArcGIS Web AppBuilder

Se devuelven los siguientes mensajes de error cuando se pasa el cursor sobre el icono de error:

Error:
Error executing tool. Export Web Map Task: Failed to create layer from service at <service URL>.
Failed to create layer from service at <service URL>.
Failed to execute (Export Web Map).
Failed to execute (Export Web Map Task).
El mensaje de error se devuelve cuando se pasa el cursor sobre el icono de error

Causa

  • Se detiene el servicio de geoprocesamiento PrintingTools.
  • El software cortafuegos o antivirus impide que el servicio se inicie bloqueando los procesos de backend.
  • No se ha borrado la caché de exploración del equipo.

Solución o solución alternativa

Utilice uno de los siguientes métodos para resolver el problema.

Note:
When using an ArcGIS Server print service with services added by the members to the portal through HTTPS, additional configuration is required. Any machine that runs the print service must be configured to trust Certificate Authority (CA) signed certificates from the site providing the HTTPS services. Refer to ArcGIS Server: Import the CA root certificate into the Windows certificate store for more information.

Inicie el servicio PrintingTools si se detiene

Vaya a ArcGIS Server Manager. Haga clic en Servicios > Administrar servicios > Utilidades. Identifique el servicio PrintingTools y haga clic en el botón Inicio.

Como alternativa, reinicie el servicio PrintingTools si el servicio se está ejecutando. Haga clic en el botón Detener y haga clic en el botón Inicio.

Realizar la configuración del firewall

Para permitir una conexión a ArcGIS Server, elimine del equipo la regla de firewall que bloquea la conexión. Consulte Cómo: Configurar ArcGIS Server para firewalls y dispositivos NAT para obtener más información.

Agregar excepciones al software antivirus

Asegúrese de disponer de las excepciones adecuadas para todos los directorios de ArcGIS Enterprise. Consulte Preguntas frecuentes: ¿Qué directorios de ArcGIS Enterprise se deben excluir para el software de seguridad o antivirus? para obtener más información sobre las excepciones de antivirus.

Borrar la caché de navegación

Borre la caché del navegador web en función del navegador web utilizado:

Usar un navegador diferente

Utilice un navegador diferente, por ejemplo, Google Chrome, Mozilla Firefox o Microsoft Edge, para iniciar sesión en Portal for ArcGIS Map Viewer e imprimir los mapas web deseados.

Id. de artículo: 000029627

Obtenga soporte con IA

Resuelva su problema rápidamente con el chatbot de inteligencia artificial de soporte de Esri.

Empieza a chatear ahora

Información relacionada

Descubrir más sobre este tema

Obtener ayuda de expertos en ArcGIS

Contactar con el soporte técnico

Empieza a chatear ahora

Ir a opciones de descarga