PROBLEM

ArcGIS and VPN: Understanding connection errors, timeouts, and performance issues when working remotely

Last Published: June 10, 2020

Description

The most common method to use Esri software remotely is through VPN, though other methods are sometimes used, such as Remote Desktop Protocol (RDP). When working with ArcGIS Desktop applications over a VPN connection, performance degradation may occur even when performing relatively lightweight operations such as creating a new feature class and adding fields, adding attribute rules, or copying a small feature class from one geodatabase to another. These issues may include:

  • Slow opening of ArcMap and ArcGIS Pro
  • Missing features when panning or zooming
  • Slow completion of geprocessing tools
  • Slow redrawing of MXDs
  • Long response times when adding or editing features
  • ArcMap not responding when adding a layer
  • Slow drawing times, or a spinning blue icon

Other issues may occur, including

  • Database connection errors
  • License manager errors
  • Latency when opening ArcGIS Server Manager
  • Blank pages and other browser errors when trying to access ArcGIS Enterprise portal home pages and web maps

This article describes some common error scenarios and provides some methods to help identify the source of these errors, and to recognize whether they arise from router, bandwidth, VPN configuration, or database connection problems. Isolation of these problems can help to identify the appropriate actions.

Note:
For a list of frequently asked questions about the general use Esri technology remotely, such as installation, license authorization, etc., see Esri Canada's blog: How to access Esri technology while working from home.

Error Messages
In addition to latency and timeouts, an the general inability to connect, numerous error messages are returned. The majority of these problems occur when working in ArcGIS applications that are connected to an RDBMS hosted on a network server, such as when working in ArcMap or Pro and connected to an enterprise geodatabase. Additional error messages may be returned that indicate License server disconnects. Some examples of typical error conditions and messages are as follows:

Lost License Connections
Messages such as the following may be returned:

License Connection Lost
Lost connection with license server for ArcGIS for Desktop Advanced (ARC/INFO).
Trying to reconnect every 120 seconds: attempt 1 of 5...

ArcGIS Desktop Errors
When VPN connection is intermittent, indicators may appear in the user interface that suggest connection errors to source data, such as red exclamation marks next to geodatabase connection files in ArcGIS Pro.

image of red exclamation points next to geodatabase connection files in ArcGIS Pro

Or broken layer data sources in map documents with red exclamation marks next to them, as shown below.

image of broken layer data sources in map documents with red exclamation points next to them

Additionally, errors such as the following are returned when saving edits, creating new features, drawing, or adding new layers in ArcMap:

Save Edits
Unable to save edits.Underlying DBMS error [ORA-03114: not connected to ORACLE]
[SDE.DEFAULT]
Failed to create new feature(s). Underlying DBMS error [sde.DEFAULT]
One or more layers failed to draw.
U.S. Cities: Failure to access DBMS server [ORA-03114: not connected to ORACLE::...]
Open failed
Error opening feature class
FDO error: -2147155559
Failure to access the DBMS server[[Microsoft][ODBC Driver 17 for SQL Server]Communication link failure] [world01.sde.GBD_Items]

General Database Connection Errors
Numerous errors may be returned when attempting to connect to a database with VPN. These messages can have varying levels of detail. Some examples are as follows:

Connection
Unable to connect to database server to retrieve database list. please verify your server name, user name, and password info and try again. Underlying DBMS error...
Error
Underlying DBMS error
Connection Error
Failed to connect to the specified DBMS instance.
A database connection error exception has occurred.
FDO error: -2147155559.

Cause

GIS applications are heavy users of network trafffic, and GIS data is commonly shared and stored from a central data repository. Most of these performance issues can be attributed to insufficient bandwidth over VPN connections, such as when working in ArcMap or ArcGIS Pro and connected to an Enterprise geodatabase. Accessing an Enterprise geodatabase, whether on Microsoft SQL Server, Oracle, or other RDBMS over an internet connection will always be slow, however some workarounds are provided below.

Some operations and workflows are more network-intensive than others, depending on the applications used, for example, ArcMap is more "chatty" than ArcGIS Pro. Moreover, if you're using a new machine for remote work, it may not yet be optimized for use with ArcGIS.

License server timeouts can occur when there is insufficient response time set in the License Manager, this can be reset, and alternative licensing usage can also alleviate License server timeout. 

Solution or Workaround

General Recommendations

Note:
While troubleshooting your environment to determine the cause, it is highly recommended to take note of any settings gathered or the results of any tests conducted, such bandwidth, database connections, network latency, etc., as this information may help the technical analysts at the support channel you seek, whether your ISP, corporate IT department, or Esri Support Services.

Start with local issues that may interfere with connections to the ArcGIS platform. Consider the bandwidth provided by your ISP. If you have sufficient bandwidth, start troubleshooting the VPN connection. Some general recommendations are:

  • Avoid having two machines using VPN on the same Wifi
  • Use a LAN cable connection to the router
  • Reboot the router
  • Ensure appropriate permissions on the OS/user profile to the VPN software on the PC
  • Make sure that there are no restrictions in terms of communications via firewalls or anti-virus applications
  • Run a network speed test. This information may be useful to determine your maximum available bandwidth. The Network Speed Test app is also available from the Microsoft store.
  • Use RDP instead of VPN

Some users may have obtained new laptops for remote work, and if a VPN or database is not suspected, the machine may require some configuration to optimize the use of ArcGIS. Some recommendations for performance tuning are linked in the Related Information section below.

Once these basic items are ruled out, it might be time to speak with your internal IT department. There are specific network recommendations that may help to optimize the ArcGIS Platform, and system architecture design may need to be reevaluated to ensure that peak traffic loads can accommodate user performance requirements, as described in System Design Process: Network Communications.

Lost License Connections
Possible solutions for this error included increasing the license timeout, borrowing licenses as opposed to continually hitting the license server, or hosting ArcGIS Pro licenses on ArcGIS Online, see:

ArcGIS Desktop Errors

  • Drawing performance in ArcMap may be improved by using a desktop-side feature cache. See: Working with the feature cache
  • Consider migrating workflows to ArcGIS Pro if possible, it is less network intensive than ArcMap, and licenses can be hosted in ArcGIS Online.
  • Create a local replica of the Enterprise geodatabase, and sync the replica later, after edits have been finished.
  • Clear the Display Cache. The display cache facilitates panning and zooming in the existing map but if the cache is retained instead of being cleared from one map to the next, there is a big performance hit. In ArcMap, click Customize > ArcMap Options. On the Display Cache tab, click Clear Cache.
  • Clear out the geoprocessing history: go to Geoprocessing > Geoprocessing Options, and under Results Management, change the setting to Never Save or Keep results younger than 1 Day.

General Database Connection Errors

  • Make sure the RDBMS client software is running and configured to allow remote connections.
  • Ensure that you are current on database maintenance and patches.
  • Run scheduled tasks to perform database maintenance overnight.

The following tests may help narrow the source of the problem, and help your technical support representative remediate the issues:
From the Command Prompt:

  • Ping the database server, note the reply times and any packet loss.
  • Run tracert. How many hops? Are there any request timeouts?
Note:
When running commands, use the IP address of the server, instead of the HOSTNAME.
  • If connecting to a database, telnet the server with the port number the database is listening on. Is it clear?
  • Review firewall settings and/or group policies, however it is not advised to disable them, even for testing.

Article ID:000023346

Software:
  • ArcMap
  • ArcGIS Pro
  • Portal for ArcGIS
  • Third Party Product

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