English

How To: Detect and quantify temporal changes using the Raster Calculator

Summary

Temporal change detection can be performed by comparing two rasters from a different time, such as detecting changes in vegetation cover or land use over a specified period. This can be done with the Raster Calculator in ArcMap, which gives results that allow further interpretation and classification for quantifying areas of change.

Note:
Using rasters that have been post-processed, enhanced, classified, or normalized usually gives more accurate change detection results than raw aerial imagery. For example, to detect vegetation cover changes, use the aerial imagery to calculate Normalized Difference Vegetation Index (NDVI) rasters for different time periods as the first step, and to detect land cover changes, classify the aerial imagery into land cover maps before comparing spatial changes over time. 

The instructions provided describe how to detect and quantify vegetation cover changes over a period of time using the Raster Calculator tool.

Procedure

  1. Subtract NDVI rasters to get difference of pixel values over time:
Note: 
The NDVI rasters must cover the same spatial extent and pixels are perfectly aligned. Furthermore, to detect annual changes, acquire NDVI rasters calculated for the same time window of the year. Otherwise, using NDVI rasters calculated in different seasons reflects the vegetation changes over seasons, not years.
  1. Navigate to Spatial Analyst Tools > Map Algebra > Raster Calculator.
  2. In the Raster Calculator dialog box, type in the expression for subtracting the raster of a previous time from the raster of a later time.
    For example:
    "NDVI 2017" - "NDVI 2015"
    User-added image
  3. Set a name and location for the Output raster.
  4. Click OK. The output raster contains the subtracted cell values. Negative values indicate losses while the positive values indicates gain, while 0 values indicate unchanged vegetation cover. 
  1. The raster generated in Step 1 can be classified into multiple classes to reflect vegetation change direction and extent, for example: a.Vegetation loss, b.No change, c.Vegetation gain, or: a.Significant loss, b.Loss, c.No change, d.Gain, e.Significant gain. 
    1. Navigate to Spatial Analyst Tools > Reclass > Reclassify.
    2. Select the output raster from Step 1 for the Input raster.
    3. Select VALUE for the Reclass field.
    4. Under the Reclassification section, click Classify....
      User-added image
    5. In the Classification dialog box, select a method for the classification in the Method drop-down list, and select the desired number of classes in the Classes drop-down list.
    6. Set the Break Values manually if needed.
      User-added image
    7. Click OK to exit the Classification dialog.
    8. In the Reclassify dialog, set a name and location for the Output raster.
    9. Click OK. A reclassified raster is generated with pixel values indicating the vegetation change classes. A Count field is added in the attribute table of the reclassified raster containing the number of cells falling into each class.
  2. Quantify the changes by creating a new field and calculating the area of each class by multiplying the Count field with the pixel size of the raster layer.
  1. Open the attribute table of the Step 2 output. Right-click the layer > Open Attribute Table.
  2. Click Table Options > Add Field.
  3. In the Add Field dialog box, type a name for the new field. Select Double as the field type. Leave other settings as default, and click OK.
  4. Right-click the new field > Field Calculator. Click Yes if any prompt dialog box appears.
  5. In the Field Calculator dialog box, multiply the Count field by the pixel size of the raster layer. For example, this raster's pixel size is 90:
    User-added image
  6. Click OK. The area for each class is calculated in the new field. The unit of the calculated area is the unit of the raster's coordinate system.
    User-added image

Related Information