PROBLEM

An error occurred while updating ArcGIS Survey123 to version 3.12 on an Android device

Last Published: April 27, 2022

Description

The Google Play Store has implemented requirements to improve the security of data used by applications stored on devices. Previously, installed applications had access to both 'public' storage and application-specific 'private' storage on the device. In Android developer terms, these are called 'external' and 'scoped' storage, respectively. Applications are now required to store all data in scoped (private) storage.

The 3.12 release of ArcGIS Survey123 includes an automatic migration process that starts when the application is opened for the first time. This process migrates original 3.11 data, including surveys and user settings to scoped storage. In some cases, the migration fails, and an error code is returned.

Cause

There are several reasons why the Android storage migration fails. Refer to the list of error codes and their descriptions below.

Solution or Workaround

For each error code, please refer to the resolution steps in the table below.

As part of the migration process, Survey123 writes a log file named ‘migration.log’ in the original ArcGIS folder on the Android device (typically found at /Internal storage/ArcGIS, /sdcard/ArcGIS, /storage/emulated/0/ArcGIS, or similar).

Note:
If the issue is not resolved using the resolution steps, retain a copy of the log file and contact Esri Support Service for further assistance.
CodeDescriptionResolution Steps
2900Application exception due to unknown errorProvide a copy of the log file and contact Esri Support for further assistance.
2901Storage access permission rejected. The user has denied the application access to the storage device.Restart the application. A dialog appears asking permission to access the storage device. Permission must be granted for the migration to proceed.
2902ArcGIS data folder not found in legacy storageRefer to the error message in the log file for the expected path to the legacy ArcGIS folder. Please confirm that this folder exists at this location.
2903Failed verification because file does not exist in destination locationRefer to the error message in the log file for the expected file not found in new storage location. 
2904Failed verification because file sizes are not equalRefer to the error message in the log file for the file which is of not equal size in the old and new storage location.
2905Storage device does not have enough free spaceRefer to the error message in the log file for the total storage device space, the available free space, and the size of the ArcGIS folders that must be copied for the migration. The minimum required space is two times the ArcGIS folder size. Manually free up storage on the device to permit the migration to occur.
2906Failed to remove legacy settings fileEnsure that no other instance of Survey123 is open, and that no other application has opened files or folders in the ArcGIS legacy storage location. Rerun the migration.
2907Failed to create folder in destination locationRestart the application. A dialog will appear asking permission to access the storage device. Permission must be granted for the migration to proceed.
2908Failed to remove existing zip archiveEnsure that no other instance of Survey123 is open, and that no other application has opened files or folders in the ArcGIS legacy storage location. Rerun the migration.
2909Failed to remove folder from legacy storageEnsure that no other instance of Survey123 is open, and that no other application has opened files or folders in the ArcGIS legacy storage location. Rerun the migration.
2910Database does not exist in scoped storage following file migrationConfirm that the survey database file exists in the legacy storage location prior to migration process.
2911Failed to update map library paths in settings fileEnsure that the settings file exists in the scoped storage location and that no other application has the file open. Rerun the migration.
2912Failed to copy data file to scoped storageRestart the application. A dialog will appear asking permission to access the storage device. Permission must be granted for the migration to proceed.
2913Failed to copy data file over an existing file in scoped storageEnsure that no other instance of Survey123 is open, and that no other application has opened files or folders in the scoped storage location. Rerun the migration.
2914Failed to open settings file for updatingEnsure that the settings file exists in the scoped storage location and that no other application has the file open. Rerun the migration.
2915Failed to update known devices pathsEnsure that the settings file exists in the scoped storage location and that no other application has the file open. Rerun the migration.
2917Failed to add file to zip archiveRerun the migration.
2918Failed to open log file for writingConfirm that the legacy data storage location exists.
2919Settings file does not exist in scoped storage following file migrationConfirm that the Survey123 settings file exists in the legacy storage location.
2920Failed to read from scoped storage during preflight testConfirm that the expected scoped storage location exists.
2921Failed to write to scoped storage during preflight testConfirm that the expected scoped storage location exists.
2922Failed to write to scoped storage during preflight testConfirm that the expected scoped storage location exists.
2923Failed to write to scoped storage during preflight testConfirm that the expected scoped storage location exists.
2924Failed to write to scoped storage during preflight testConfirm that the expected scoped storage location exists.
2925Failed to write to scoped storage during preflight testConfirm that the expected scoped storage location exists.
2926Failed to write zip archiveRerun the migration.

Article ID:000025129

Software:
  • ArcGIS Survey123 Field App Android

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options

Related Information

Discover more on this topic