PROBLEM

Unable to open an ArcGIS Workforce project

Last Published: December 9, 2024

Description

Attempts to open a project in ArcGIS Workforce as the project owner within ArcGIS Online or ArcGIS Enterprise fail and return the following error:

Error:
Unable to open project
The error message

Cause

The issue typically occurs when the project ownership is transferred to a new owner, and

  • the user is not assigned the dispatcher role in the project, or
  • the user is not the project's group owner, or
  • the user does not own all content associated with the project, or
  • the project is accessed through HTTP.

Solution or Workaround

Depending on the cause, the workarounds provided are applicable.

Assign the dispatcher role to the user

  1. Sign in to ArcGIS Workforce with ArcGIS Online or ArcGIS Enterprise administrator credentials.
  2. On the My Projects tab, hover over the project and click Configure.
The Configure icon on the project card
  1. On the Users tab, for Organization User, search for and select the project owner's name.
  2. For Project Role, select Dispatcher from the drop-down menu.
  3. Click +User.

The image below shows the project owner with the dispatcher role.

The project's user list.

Assign the user as the group owner

In ArcGIS Online or the ArcGIS Enterprise portal, open the ArcGIS Workforce group and assign the user as the group owner. To change the group ownership, refer to ArcGIS Online: Edit group properties and settings or Portal for ArcGIS: Edit group properties and settings.

Change ownership of content associated with the project

ArcGIS Workforce supports integration with other ArcGIS web apps such as ArcGIS Field Maps and ArcGIS Survey123. Therefore, ensure the associated content, including feature layers, web maps, apps, and form items, are owned by the project owner. To change the item ownership, refer to ArcGIS Online: Change the owner or Portal for ArcGIS: Change owner.

Access the project through HTPPS

Although an ArcGIS Enterprise organization may allow HTTP communication, access the ArcGIS Workforce project through HTTPS to resolve the issue.

Article ID: 000032693

Software:
  • ArcGIS Online
  • Portal for ArcGIS
  • ArcGIS Workforce
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 2
  • ArcGIS Enterprise 11 4

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Related Information

Discover more on this topic

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options