PROBLEM

Shapefile features do not display when zooming or panning in ArcMap

Last Published: March 10, 2021

Description

When zooming or panning in a shapefile in ArcMap, some features no longer display.

Cause

The shapefile's spatial index is stale or corrupt.

Solution or Workaround

Note: 
Backup the shapefile before performing the steps provided.
  1. Start Windows Explorer.
  2. Navigate to the folder wherein the shapefile is stored.
  3. Look for two files with SBX and SBN extensions. If the shapefile is called PARCELS, the files that form the spatial index are PARCELS.SBN and PARCELS.SBX.
  4. Delete the two files. If there is only one file, delete it.
  5. Open ArcMap. Pan and zoom to check if the problem is resolved.
  6. If deleting the spatial index fixes the problem of features not displayed, a new spatial index can be created in ArcCatalog. Refer to How To: Build a spatial index for a shapefile for steps to do this.
Note:
If this solution does not resolve the problem, refer to the Related Links section for more help guides.

Article ID: 000006099

Software:
  • ArcMap

Receive notifications and find solutions for new or common issues

Get summarized answers and video solutions from our new AI chatbot.

Download the Esri Support App

Get help from ArcGIS experts

Contact technical support

Download the Esri Support App

Go to download options