Description
When zooming or panning in a shapefile in ArcMap, some features no longer display.
Cause
The shapefile's spatial index is stale or corrupt.
Solution or Workaround
Note:
Backup the shapefile before performing the steps provided.
- Start Windows Explorer.
- Navigate to the folder wherein the shapefile is stored.
- Look for two files with SBX and SBN extensions. If the shapefile is called PARCELS, the files that form the spatial index are PARCELS.SBN and PARCELS.SBX.
- Delete the two files. If there is only one file, delete it.
- Open ArcMap. Pan and zoom to check if the problem is resolved.
- If deleting the spatial index fixes the problem of features not displayed, a new spatial index can be created in ArcCatalog. Refer to How To: Build a spatial index for a shapefile for steps to do this.
Note:
If this solution does not resolve the problem, refer to the Related Links section for more help guides.