PROBLEM

Layers fail to display in PDF exported from ArcGIS Pro

Last Published: January 23, 2025

Description

After exporting a map layout to PDF, certain layers such as feature classes or raster images are not displayed. The exported PDF only displays legends, text, and other map elements. The PDF document below shows the map layout exported from ArcGIS Pro.

The exported PDF

Cause

  • The ArcGIS Pro session experiences glitches or memory issues.
  • The feature layers saved on a network drive, cloud storage, or in databases such as SQL Server, Oracle, ArcGIS Enterprise, or PostgreSQL are corrupted, broken, or fail to sync and update in ArcGIS Pro.
  • The ArcGIS Pro installation is corrupted, or some files are missing.

Solution or Workaround

Note:
This issue is resolved in ArcGIS Pro 3.5. The following options apply to earlier versions of ArcGIS Pro.

Depending on the cause, the following options are applicable.

Reopen the project or re-add the layer to the project

In ArcGIS Pro, save all recent edits and close the project. To restore the project, reopen the project. Refer to ArcGIS Pro: Open a project for instructions.

Alternatively, remove the layer from the project and re-add the layer to the project. To remove the layer, right-click the layer in the Contents pane and click Remove. To re-add the layer, refer to ArcGIS Pro: Add layers to a map or scene for instructions and more information.

Save the layer in a file geodatabase

Use the Feature Class To Geodatabase tool to save the layer in a file geodatabase. Saving layers to a local machine improves access speed and reduces the risk of data syncing or connectivity issues. If the layer is not a feature class, use the Export Features tool to save the layer in a file geodatabase. Refer to How To: Export a feature service to a file geodatabase feature class in ArcGIS Pro for instructions.

Repair ArcGIS Pro

Repair ArcGIS Pro to resolve the issues caused by corrupted installation files, missing components, or misconfigurations that affect the ArcGIS Pro performance and functionality. Refer to Microsoft Support: Repair apps and programs in Windows for instructions.

Optionally, perform a soft reset in ArcGIS Pro. Refer to How To: Perform an ArcGIS Pro soft reset for instructions. This resets ArcGIS Pro's settings without affecting the project or data.

Article ID: 000034459

Software:
  • ArcGIS Pro 3 3
  • ArcGIS Pro 3 2
  • ArcGIS Pro 3 4

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