PROBLEM

Inconsistent query results in ArcGIS Server Manager logs

Last Published: June 26, 2024

Description

In some instances, when accessing the server logs in ArcGIS Server Manager, the logs show inconsistent results. For example, for certain filters, the first query shows the correct results, whereas the subsequent queries show incorrect or odd results.

Cause

The log files are corrupted in ArcGIS Server Manager, as the logs can be viewed in the ArcGIS Server Administrator Directory without any inconsistencies.

Solution or Workaround

Perform the clean operation. The clean operation forces the server to clean the logs, freeing up disk space.

Warning:   
This operation is irreversible. Once invoked, this operation deletes all logs on every server machine on the site.
Note:
It is recommended to create a backup of the ArcGIS Server site configuration before proceeding with the following steps. Refer to ArcGIS Server: Making a backup of your site for instructions.
  1. Log in to the ArcGIS Server Administrator Directory as an administrator. The default URL is:
https://<gisserver>.<domain.com>:6443/arcgis/admin
  1. For Resources, click logs.
  2. For Supported Operations, click clean.
  3. On the Clean Logs page, select an appropriate format from the Format drop-down menu and click Clean.
  4. Restart the ArcGIS Server service. Refer to ArcGIS Server: Start and stop services for instructions.
Note:
Do not copy the old logs from the backup folder to the newly cleaned directory. If required, explore the old logs from the backup folder.

Article ID:000032770

Software:
  • ArcGIS Enterprise 11 2
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 1
  • ArcGIS Server

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