Error Message
When attempting to log in to the ArcGIS Enterprise portal, the following error message is returned:
Error:
Unable to sign in user because of a software authorization error. Please contact your ArcGIS Enterprise administrator for assistance.
Cause
- The portal administrator or member login credentials used to access the ArcGIS Enterprise portal has been deleted or is unknown.
- The portal license file is either inaccessible in My Esri or has expired.
- The limit on the number of user types has been exceeded.
Solution or Workaround
Create a temporary administrator account using the Create Administrator Account utility
Create a temporary account to reset the portal administrator password or create a new portal account with administrative privileges. Refer to Portal for ArcGIS: Recovering the portal when no administrator accounts are available for instructions.
If a member is deleted, the account is permanently removed from the identity store and cannot be recovered. Organization-specific accounts (SAML and OpenID Connect) are unregistered from the portal and retained in the identity store. If necessary, recover the organization-specific account by adding it back to the portal.
Create a license file for Portal for ArcGIS and import it into the portal
- Obtain a new license file. Refer to Portal for ArcGIS: Obtain a portal license file from My Esri for instructions.
- Import the new license file to the portal. Refer to Portal for ArcGIS: Import licenses for instructions.
Revoke the license file that has exceeded the number of user types and generate a new license file
- Cancel the license file with the exceeded user type. Refer to How To: Cancel license files for Portal for ArcGIS in My Esri for instructions.
- Follow Steps 1 and 2 mentioned in the 'Create a license file for Portal for ArcGIS and import it into the portal' section above.