ERROR

Portal for ArcGIS: Failed to determine if item can be deleted

Last Published: November 27, 2024

Error Message

Attempts to delete items from the Settings tab of the item page in Portal for ArcGIS fail with the following error returned:

Error:   
Failed to determine if item can be deleted: <itemID>
Error message.jpg

Cause

  • Insufficient permission to delete the item or ownership conflict exists.
  • Detached item references within Portal for ArcGIS, where the corresponding services have been deleted from ArcGIS Server but persist in the portal environment.

Solution or Workaround

Depending on the cause, the following workarounds are applicable.

Change the ownership of the item

  1. Transfer the item's ownership to another user to bypass issues related to permissions, dependencies, or system validation errors. Refer to Portal for ArcGIS: Change owner for instructions.
  2. Delete the item after the ownership is changed. Refer to Portal for ArcGIS: Delete items owned by others for instructions.

Remove the folder containing the items

Manually delete the folder containing the items. Refer to Error: Unable to delete item for instructions.

Article ID: 000033957

Software:
  • Portal for ArcGIS
  • ArcGIS Enterprise 11 1
  • ArcGIS Enterprise 11 3
  • ArcGIS Enterprise 11 2

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