Error Message
Attempts to stop map services in ArcGIS Server Manager, ArcCatalog or ArcGIS REST API fail, and may return the following error messages:
Failed to stop one or more services: [<service_name>.MapServer]. null
Or,
Failed to start one or more services. 'com.esri.arcgis.discovery.admin.AdminException'
Cause
There are RLOCK and DAT files of non-participating machines in the configuration store of the ArcGIS Server site.
Solution or Workaround
To resolve, follow the instructions described below.
- Stop the ArcGIS Server Windows service in each of the participating machines of the ArcGIS Server site.
- Right-click the Windows taskbar, and select Task Manager to open Windows Task Manager.
- In the Task Manager window, click the Services tab.
- Right-click ArcGIS Server, and click Stop.
- Navigate to the default cluster folder in the configuration store.
<shared_network_drive>\arcgis\arcgisserver\config-store\clusters\default
- Delete all the RLOCK (.dat.rlock) and DAT (.dat ) files of the non-participating machines in the ArcGIS Server site.
- Restart the ArcGIS Server Windows service in each of the participating machines of the ArcGIS Server site.
- Right-click the Windows taskbar, and select Task Manager to open Windows Task Manager.
- In the Task Manager window, click the Services tab.
- Right-click ArcGIS Server, and click Start.