ERROR

Failed to stop one or more services: [<service_name>.MapServer]. null or Failed to start one or more services. 'com.esri.arcgis.discovery.admin.AdminException'

Last Published: October 11, 2022

Error Message

Attempts to stop map services in ArcGIS Server Manager, ArcCatalog or ArcGIS REST API fail, and may return the following error messages:

Failed to stop one or more services: [<service_name>.MapServer]. null

Or,

Failed to start one or more services. 'com.esri.arcgis.discovery.admin.AdminException'
FailedtoStart.PNG

Cause

There are RLOCK and DAT files of non-participating machines in the configuration store of the ArcGIS Server site.

Solution or Workaround

To resolve, follow the instructions described below.

  1. Stop the ArcGIS Server Windows service in each of the participating machines of the ArcGIS Server site.
    1. Right-click the Windows taskbar, and select Task Manager to open Windows Task Manager.
    2. In the Task Manager window, click the Services tab.
    3. Right-click ArcGIS Server, and click Stop.
Task Manager window.
  1. Navigate to the default cluster folder in the configuration store.
<shared_network_drive>\arcgis\arcgisserver\config-store\clusters\default
  1. Delete all the RLOCK (.dat.rlock) and DAT (.dat ) files of the non-participating machines in the ArcGIS Server site.
Default cluster folder.
  1. Restart the ArcGIS Server Windows service in each of the participating machines of the ArcGIS Server site.
    1. Right-click the Windows taskbar, and select Task Manager to open Windows Task Manager.
    2. In the Task Manager window, click the Services tab.
    3. Right-click ArcGIS Server, and click Start.

Article ID:000022294

Software:
  • ArcGIS Server

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