ERROR

Failed to return borrowed license in ArcGIS Pro

Last Published: February 21, 2024

Error Message

When attempting to return a borrowed Concurrent Use license in ArcGIS Pro, the process fails and the following error message is returned:

Error:
Failed to return borrowed license.
Error failed to return borrowed license

Cause

  • Network issues. In some cases, the ArcGIS License Manager may be hosted on a virtual machine (VM), while the machine running ArcGIS Pro resides on a local network. If these machines are on different networks, it can lead to connectivity issues.
  • The user does not have the administrative privileges to return the borrowed license.
  • ArcGIS License Manager is not accessible through the firewall.
  • The license file is corrupted.

Solution or Workaround

Depending on the cause, the workarounds below are applicable.

Note:
For the workarounds provided, ensure the 'Authorize ArcGIS Pro to work offline' check box is unchecked on the Licensing page of ArcGIS Pro.

Connect the machine to the same network as ArcGIS License Manager

Connect the machine to the same network as ArcGIS License Manager to ensure consistent network connectivity. Connectivity issues can arise from weak or unstable internet connections. For example, consider connecting to the same VPN as the ArcGIS License Manager.

Note:
This issue also occurs when the License Manager Server's IP Address and the Host name are mismatched with the IP address and Host name in the 'hosts' file. Refer to Bug: ArcGIS Desktop resolves only the hostname (and not the fully qualified domain name) when returning a borrowed license for additional information.

Use an administrator account to return the borrowed license

Use an account with administrative privileges to log in to ArcGIS Pro and return the borrowed license. Refer to Portal for ArcGIS: Administrative privileges for additional information.

Configure ArcGIS License Manager to be accessible through the firewall

Note:
The following workflow may require some assistance from the organization's IT department.

Configure ArcGIS License Manager to be accessible through the firewall. Refer to License Manager Guide: Configure ArcGIS License Manager to work through a firewall for instructions.

Clear the trusted storage, recover, and authorize the license

  1. Clear the trusted storage on the machine. Refer to How To: Clear or delete trusted storage for concurrent-use and single-use licenses for instructions.
  2. Recover the license file from My Esri. Refer to How To: Recover lost licenses from My Esri for instructions.
  3. Authorize a replacement license on ArcGIS License Manager. Refer to ArcGIS Pro: Authorize Concurrent Use licenses for instructions and more information.
  4. Configure ArcGIS Pro to use the authorized license. Refer to ArcGIS Pro: Set the license type to Concurrent Use for instructions and more information.

Article ID:000030962

Software:
  • ArcGIS Pro 3 2
  • ArcGIS Pro 3 0
  • ArcGIS Pro 3 1

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