ERROR

ArcGIS Pro: Failed to borrow application license

Last Published: October 14, 2024

Error Message

In ArcGIS Pro authorized with a Concurrent Use license, attempts to check the 'Authorize ArcGIS Pro to work offline' check box fail and returns the following error message:

Error:
Failed to borrow application license.
The Failed to borrow application license error message

Cause

  • The 'Allow License Borrowing' check box is unchecked in the ArcGIS License Server Administrator.
  • The license file is corrupted.

Solution or Workaround

Depending on the cause, use one of the following workflows:

Enable the 'Allow License Borrowing' check box

In the ArcGIS License Server Administrator, check theĀ Allow License Borrowing check box. Refer to License Manager Guide: Configuring license borrowing for instructions.

Clear the trusted storage, recover, and authorize the license

If checking the 'Allow License Borrowing' does not resolve the issue, perform the following workflow:

  1. Clear the trusted storage on the machine. Refer to How To: Clear or delete trusted storage for concurrent-use and single-use licenses for instructions.
  2. Recover the license file from My Esri. Refer to How To: Recover lost licenses from My Esri for instructions.
  3. Authorize a replacement license on ArcGIS License Manager. Refer to ArcGIS Pro: Authorize Concurrent Use licenses for instructions and more information.
  4. Configure ArcGIS Pro to use the authorized license. Refer to ArcGIS Pro: Set the license type to Concurrent Use for instructions and more information.

Article ID: 000033713

Software:
  • Other
  • ArcGIS Pro 3 1
  • ArcGIS Pro 3 3
  • ArcGIS Pro 3 2

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