ERROR

Fehler beim Zurückgeben der ausgeliehenen Lizenz in ArcGIS Pro

Last Published: February 21, 2024

Fehlermeldung

Beim Versuch, eine ausgeliehene Concurrent-Use-Lizenz in ArcGIS Pro zurückzugeben, schlägt der Vorgang mit der folgenden Fehlermeldung fehl:

Error:
Failed to return borrowed license.
Fehler beim Zurückgeben der ausgeliehenen Lizenz

Ursache

  • Netzwerkprobleme. Bei einigen Umgebungen ist ArcGIS License Manager auf einer virtuellen Maschine (VM) gehostet, während sich der Computer, auf dem ArcGIS Pro ausgeführt wird, in einem lokalen Netzwerk befindet. Wenn sich diese Computer in unterschiedlichen Netzwerken befinden, kann dies zu Verbindungsproblemen führen.
  • Der Benutzer verfügt nicht über die Administratorberechtigungen, um die ausgeliehene Lizenz zurückzugeben.
  • ArcGIS License Manager ist nicht über die Firewall erreichbar.
  • Die Lizenzdatei ist beschädigt.

Lösung oder Problemumgehung

Je nach Fehlerursache stehen die folgenden Workarounds zur Verfügung.

Note:
For the workarounds provided, ensure the 'Authorize ArcGIS Pro to work offline' check box is unchecked on the Licensing page of ArcGIS Pro.

Verbinden des Computers mit demselben Netzwerk wie ArcGIS License Manager

Verbinden Sie für eine konsistente Netzwerkkonnektivität den Computer mit demselben Netzwerk wie ArcGIS License Manager. Ursachen von Verbindungsproblemen können schwache oder instabile Internetverbindungen sein. Stellen Sie zum Beispiel eine Verbindung mit dem VPN her, in dem ArcGIS License Manager ausgeführt wird.

Note:
This issue also occurs when the License Manager Server's IP Address and the Host name are mismatched with the IP address and Host name in the 'hosts' file. Refer to Bug: ArcGIS Desktop resolves only the hostname (and not the fully qualified domain name) when returning a borrowed license for additional information.

Verwenden eines Administratorkontos, um die ausgeliehene Lizenz zurückzugeben

Verwenden Sie ein Konto mit Administratorberechtigungen, um sich bei ArcGIS Pro anzumelden und die ausgeliehene Lizenz zurückzugeben. Weitere Informationen finden Sie unter Portal for ArcGIS: Administratorberechtigungen.

Konfigurieren des Zugriffs auf ArcGIS License Manager über die Firewall

Note:
The following workflow may require some assistance from the organization's IT department.

Konfigurieren Sie ArcGIS License Manager so, dass er über eine Firewall erreichbar ist. Weitere Informationen finden Sie unter Leitfaden zu License Manager: Konfigurieren von ArcGIS License Manager für die Verwendung mit einer Firewall .

Löschen des Trusted Storage, Wiederherstellen und Autorisieren der Lizenz

  1. Löschen Sie den Trusted Storage auf dem Computer. Anweisungen finden Sie unter How To: Leeren oder Löschen des Trusted Storage für Concurrent- und Single-Use-Lizenzen.
  2. Stellen Sie die Lizenzdatei von My Esri wieder her. Anweisungen finden Sie unter How To: Wiederherstellen verloren gegangener Lizenzen über My Esri.
  3. Autorisieren Sie eine Ersatzlizenz in ArcGIS License Manager. Anweisungen und weitere Informationen finden Sie unter ArcGIS Pro: Autorisieren von Concurrent-Use-Lizenzen.
  4. Konfigurieren Sie ArcGIS Pro für die Verwendung der autorisierten Lizenz. Anweisungen und weitere Informationen finden Sie unter ArcGIS Pro: Festlegen des Lizenztyps auf "Concurrent Use".

Artikel-ID: 000030962

Holen Sie sich Unterstützung mit KI

Lösen Sie Ihr Problem schnell mit dem Esri Support AI Chatbot.

Beginnen Sie jetzt mit dem Chatten

Zugehörige Informationen

Weitere Informationen zu diesem Thema erkunden

Unterstützung durch ArcGIS-Experten anfordern

An den technischen Support wenden

Beginnen Sie jetzt mit dem Chatten

Zu Download-Optionen wechseln