How To: Import XY data tables to ArcMap and convert the data to a shapefile


The steps below give instructions for formatting XY data, in decimal degrees, using Microsoft Excel, and converting these data to a shapefile or geodatabase feature class in ArcMap.

There are several table formats that ArcMap can read to bring point data into ArcMap as an event theme.

At version 9.1 and earlier, ArcMap can read the following formats: DBase III, DBase IV, .prn, .txt, and .csv. If they exist, extra sheets must be deleted from these formats in Excel.
At version 9.2 and later versions, ArcMap can read the above formats along with .xls and .xlsx spreadsheets.



  1. To ensure ArcMap reads the data in the file correctly, use Excel to format the columns containing the Longitude (X, or Easting) and Latitude (Y, or Northing) values as NUMBER, with a minimum of 8 decimal places.
    The graphic below shows the distribution of positive and negative values for longitude (X) and latitude (Y) coordinates worldwide.

    [O-Image] Decimal degree coordinates and signs
  2. Descriptions of the contents of each column are also required in the output file. Label columns ID, Longitude, Latitude, Description, etc.
  3. After formatting the file, select all the cells in populated rows and columns in the table and navigate to File > Print Area > Set Print Area, or Page Layout > Print Area > Set Print Area.
  4. Navigate to File > Save As, and select a supported format from the choices available in Excel. Click Yes if Excel warns that certain formatting is not supported in this file format.
  5. Exit Excel. Click No when Excel prompts to save the changes.
    If the changes are saved, Excel converts the file to an .xls or .xlsx Workbook that can only be used in ArcMap at version 9.2 and newer versions.
  6. To add the data from the .dbf, .csv, .txt or .prn file to ArcMap, navigate to Tools > Add XY Data and select the file. In version 10.x, click the Add Data button.
  7. Right-click the table name and select Display XY Data.
    At version 10.x, ArcMap applies the coordinate system of the Data Frame to the XY Data. This coordinate system is likely to be wrong for the data.

    Click the Edit button to open the Spatial Reference Properties dialog box. Click the Select button to select a coordinate system for the data.
    If a warning message regarding the missing Object-ID field is displayed, it is safe to ignore it and click OK. 

    As an example, GPS data is most often collected in units of decimal degrees or lat/long, which is a geographic coordinate system. Open this directory. Most frequently, GPS data is collected on the WGS 1984 datum, so open the World folder, and select WGS_1984.prj.

    If the data has been collected on a different datum, click the link titled "Geographic Coordinate Systems and Areas of Use" in the Related Information section below to find the appropriate datum.
  8. After defining the projection, click Add, Apply, and OK on the Spatial Reference Properties dialog box. Click OK on the Add XY Data dialog box. The points are drawn as an event theme in ArcMap. Verify that the Event theme aligns with the other data in ArcMap.
    If the data does not align with the reference data, refer to Knowledge Base article 7880 (previously 29129), titled Identify the spatial reference, projection, or coordinate system of data.
  9. To convert the event theme to a shapefile or geodatabase feature class, right-click the file name and select Data > Export Data. The points can be exported to a geodatabase feature class or to a shapefile.
  10. The data can also be re-projected to the coordinate system of the ArcMap data frame during this process. Go to View > Data Frame Properties > Coordinate System tab, and select the desired output projection for the output data. To project while exporting, right-click the Events theme, select Data > Export Data, and change the radio button to export to the "coordinate system of the data frame". The output data is in the selected output coordinate system.
  11. To project the event layer to a projected coordinate system using the Project tool, follow the instructions below:
    a. In ArcMap, navigate to ArcCatalog > Toolboxes > System Toolboxes > Data Management Tools > Projections and Transformation > Project.
    b. In the Project tool dialog box, fill the required parameters.

    Input Dataset or Feature Class: The feature class, feature layer, or feature dataset to be projected.
    Input Coordinate System (optional): The coordinate system of the input feature class or dataset.
    Output Coordinate System: The coordinate system to which the input data is to be projected.
    Geographic Transformation (optional): To be used to convert data between two geographic coordinate systems or datums.

    c. Click OK.
    If ArcMap warns of a "different geographic coordinate system than other data in the map", navigate to View > Data Frame Properties > Coordinate System tab, and click the Transformations button to verify that the correct datum transformation is being used for the area where the data is located.
    For a list of geographic (datum) transformations and their areas of use, click the link "Select the correct geographic (datum) transformation when projecting between datums". Under the Related Information section of the article, download the list of transformations for the version of ArcGIS Desktop installed on the computer.

Related Information