问题

问题:升级 ArcGIS Desktop 后 ArcGIS Administrator 中 UMN ID 缺失

Last Published: January 1, 2021

描述

升级 ArcGIS Desktop 时,升级过程失败,未返回错误消息。 启动 ArcGIS Administrator 并导航至计算机详细信息窗口将显示缺失 UMN ID。 计算机的 UMN ID 是重要的信息,因为它用于帮助恢复丢失的许可和创建 Esri 安全许可证文件 (ESLF)。

原因

升级 ArcGIS Desktop 时,安装程序将停止 FNPLicensingService 以使安装顺利进行。 但是,当第三方软件正在使用 FNPLicensingService 时,安装程序无法停止服务。 这使得安装程序无法升级 ArcGIS Desktop 和 FNPLicensingService。

解决方案或解决方法

重新安装软件之前,卸载 ArcGIS Desktop 并停止 FNPLicensingService。

: 停止服务可能影响其他使用服务的程序。 确保在执行以下解决方法之前关闭所有其他程序。
  1. 启动 Windows“控制面板”,然后选择程序和功能
  2. 右键单击 ArcGIS Desktop,然后选择卸载。 请按照屏幕上的说明完成卸载过程。
  3. 启动 Windows 服务,然后搜索 FlextNet 许可服务FlexNet 许可服务 64
  4. 右键单击各个服务,然后选择属性
  5. FlexNet 许可服务属性FlextNet 许可服务 64 属性窗口中,单击停止以停止服务。
  6. 重新安装 ArcGIS Desktop 的最新版本。
  7. 启动 Windows 服务,然后搜索 FlextNet 许可服务FlexNet 许可服务 64
  8. 右键单击各个服务,然后选择属性
  9. FlexNet 许可服务属性FlextNet 许可服务 64 属性窗口中,单击开始以开始服务。

文章 ID: 000013378

获得人工智能支持

使用 Esri Support AI Chatbot 快速解决您的问题。

立即开始聊天

相关信息

发现关于本主题的更多内容

获取来自 ArcGIS 专家的帮助

联系技术支持部门

立即开始聊天

转至下载选项