PROBLEMA

Não foi possível criar uma cópia de segurança do Portal for ArcGIS usando o utilitário webgisdr devido a itens inacessíveis no diretório de conteúdo

Last Published: January 1, 2021

Descrição

Ao executar o utilitário webgisdr para criar a cópia de segurança do Portal for ArcGIS, o processo falha, retornando o seguinte erro:

Erro: { "error":{ "code":500, "details": null, "message": "Falha ao exportar site. Falha na exportação do repositório do Portal. \\\\PortalDirectory\\arcgisportal\\content\\items\\" } }

Causa

O Portal for ArcGIS não consegue encontrar a localização dos dados de item relevante para criar a cópia de segurança, pois o item não existe mais no diretório de conteúdo do Portal.

Em um ambiente federado, quando um serviço com recursos de acesso à feição é publicado como um serviço hospedado, ocorre o seguinte:

  • Os dados são copiado no ArcGIS Data Store relacional.
  • Um serviço da feição hospedado é criado no servidor de hospedagem do portal.
  • Um item da camada de feição hospedada é criado no portal.

Se o servidor de hospedagem for removido ou não estiver configurado corretamente após a realização de uma atualização, um item poderá ser exibido no diretório de conteúdo, mas não poderá ser acessado. A tentativa de excluir este item resulta em um erro, e excluir a pasta de item do diretório de conteúdo não o remove. Reindexar não resolve o problema.

Solução ou Solução Provisória

Siga a solução alternativa abaixo para resolver.

  1. Navegue até o Portal para URL de admin do ArcGIS. A URL é:
https://<nome_máquina>.<domain>.com/<webadaptorhost>/portaladmin
  1. Navegue até Federação > Servidores > nome_servidor >Atualizar. Selecione Servidor de Hospedagem da lista suspensa Papel do Servidor e clique em Atualizar Servidor.
  2. Inicie Serviços do Windows, e procure pelo serviço do Portal for ArcGIS. Clique com o botão direito no serviço e selecione Parar.
  3. Se a pasta de conteúdo foi excluída, restaure a pasta excluída da Lixeira do Windows.
Nota: Para itens sem pastas de conteúdo para restaurar, crie uma nova pasta com o mesmo nome de ID do item de conteúdo e copie e cole quaisquer subpastas de outro item.
  1. Inicie Serviços do Windows, e procure pelo serviço do Portal for ArcGIS. Clique com o botão direito no serviço e selecione Iniciar.
  2. Navegue até a página Conteúdo do Portal for ArcGIS e exclua os itens relevantes. O processo de exclusão foi bem-sucedido, pois o item agora está acessível para o Portal.
  3. Execute novamente o utilitário webgisdr para concluir a cópia de segurança do Portal for ArcGIS.

ID do Artigo:000019078

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com suporte técnico

Baixe o Esri Support App

Ir para opções de download

Informações Relacionadas

Descubra mais sobre este tema