Instrução

não é possível excluir um aplicativo no Portal for ArcGIS

Last Published: May 16, 2024

Descrição

No Portal for ArcGIS, ao tentar criar um aplicativo ou fazer uma cópia de um aplicativo existente, o processo é interrompido indefinidamente. Em alguns casos, apesar do processo paralisado, o aplicativo ainda é criado quando o processo é encerrado. No entanto, o aplicativo resultante não pode ser excluído utilizando as credenciais de administrador do portal no site inicial do Portal.

Causa

Determinados índices do portal estão corrompidos, o que impede que os índices sejam sincronizados com as alterações mais recentes.

Solução ou Solução Provisória

  1. Exclua o aplicativo criado na página Portal Sharing REST
    1. Navegue até a página Portal Sharing Rest e efetue o login com credenciais de administrador usando o seguinte URL:
https://<portal_domain>.com/<portal_webadaptor_name>/sharing/rest
  1. Navegue até Recursos relacionados > Conteúdo do usuário.
  2. Localize e selecione o item que requer exclusão.
  3. Na página Item do usuário , role para baixo e verifique se o parâmetro Protected está definido como false.
Note:
If the Protected parameter is set to true, navigate to Supported Operations and click Unprotect. On the Unprotect Item page, select an appropriate format and click Unprotect Item.
  1. Clique em Pode excluir item.
  2. Na página Pode excluir item , clique em Pode excluir item? e verifique se ele retorna 'true'.
  3. Navegue de volta para a página Item do usuário e clique em Excluir item.
  4. Na página Excluir item , marque a caixa de seleção Forçar exclusão? , selecione um formato apropriado e clique em Excluir item.
  1. Execute uma reindexação completa do Administrador do Portal.
    1. Navegue até o Portal Administrator Directory como administrador utilizando a seguinte URL:
https://<machine_name>.<domain_name>.com/webadaptor/portaladmin
  1. Vá para Sistema > Indexar > Reindexar.
  2. Para Modo, selecione Completo na lista suspensa.
  3. Para Formato, selecione um formato de resposta na lista suspensa.
  4. Clique em Reindexar.

ID do Artigo: 000032127

Obtenha suporte com IA

Resolva seu problema rapidamente com o chatbot de IA de suporte da Esri.

Comece a conversar agora

Informações Relacionadas

Descubra mais sobre este tema

Obtenha ajuda de especialistas do ArcGIS

Entre em contato com Suporte Técnico

Comece a conversar agora

Ir para as opções de download