Descrição
No Portal for ArcGIS, ao tentar criar um aplicativo ou fazer uma cópia de um aplicativo existente, o processo é interrompido indefinidamente. Em alguns casos, apesar do processo paralisado, o aplicativo ainda é criado quando o processo é encerrado. No entanto, o aplicativo resultante não pode ser excluído utilizando as credenciais de administrador do portal no site inicial do Portal.
Causa
Determinados índices do portal estão corrompidos, o que impede que os índices sejam sincronizados com as alterações mais recentes.
Solução ou Solução Provisória
- Exclua o aplicativo criado na página Portal Sharing REST
- Navegue até a página Portal Sharing Rest e efetue o login com credenciais de administrador usando o seguinte URL:
https://<portal_domain>.com/<portal_webadaptor_name>/sharing/rest
- Navegue até Recursos relacionados > Conteúdo do usuário.
- Localize e selecione o item que requer exclusão.
- Na página Item do usuário , role para baixo e verifique se o parâmetro Protected está definido como false.
Note:
If the Protected parameter is set to true, navigate to Supported Operations and click Unprotect. On the Unprotect Item page, select an appropriate format and click Unprotect Item.
- Clique em Pode excluir item.
- Na página Pode excluir item , clique em Pode excluir item? e verifique se ele retorna 'true'.
- Navegue de volta para a página Item do usuário e clique em Excluir item.
- Na página Excluir item , marque a caixa de seleção Forçar exclusão? , selecione um formato apropriado e clique em Excluir item.
- Execute uma reindexação completa do Administrador do Portal.
- Navegue até o Portal Administrator Directory como administrador utilizando a seguinte URL:
https://<machine_name>.<domain_name>.com/webadaptor/portaladmin
- Vá para Sistema > Indexar > Reindexar.
- Para Modo, selecione Completo na lista suspensa.
- Para Formato, selecione um formato de resposta na lista suspensa.
- Clique em Reindexar.