Descrição
Ao publicar uma pesquisa no ArcGIS Survey123 Connect para ArcGIS Online ou no portal do ArcGIS Enterprise, o processo é carregado, mas não concluído, parando em 'Criando item de formulário', conforme mostrado na imagem abaixo.
Causa
- O XLSForm com o mesmo nome é usado em várias pesquisas. Utilizar o mesmo nome de formulário XLSForm em várias pesquisas causa problemas, pois cada pesquisa deve ter um ID de formulário único.
- O XLSForm contém tamanhos de arquivo grandes na pasta de mídia. Um alto volume de arquivos de imagem, arquivos de áudio ou grandes arquivos de mapa base personalizados resulta em problemas durante a publicação.
Solução ou Solução Provisória
Salve o XLSForm com um nome diferente antes de criar um novo questionário
- Na máquina local, navegue até a pasta de pesquisa localizada em:
C:\Users\<username\ArcGIS\My Survey Designs\<survey_title>
- Renomeie e salve o XLSForm da pesquisa. Certifique-se de que não haja pesquisas ou camadas de feição com o mesmo nome no ArcGIS Online ou no portal do ArcGIS Enterprise.
- Crie uma nova pesquisa usando o XLSForm.
- No ArcGIS Survey123 Connect, clique em Nova pesquisa.
- Entre na organização do ArcGIS.
- Em Título, especifique um título para a nova pesquisa.
- Para Criar um novo formulário de pesquisa, selecione a opção Arquivo.
- Para o arquivo XLSForm, clique em Selecionar, procure e selecione o XLSForm salvo na Etapa 1.
- Clique em Criar pesquisa.
- Clique no botão Publicar para publicar a nova pesquisa.
Remova o arquivo grande da pasta de mídia da pesquisa
- Abra a pesquisa no ArcGIS Survey123 Connect e clique na guia Mídia.
- Clique em Abrir pasta de mídia, navegue até o item e exclua o item.
Como alternativa, exclua diretamente o item da pasta de mídia na máquina local localizada em:
C:\Users\<username>\ArcGIS\My Survey Designs\<survey_title>\media