PROBLEMA

As licenças não são liberadas após fechar uma sessão do ArcGIS

Last Published: November 24, 2020

Descrição

Após fechar uma sessão do ArcGIS, a licença não é devolvida ao grupo de licenças disponíveis.

Nota: Este artigo refere-se às versões do ArcGIS 8.x e 9.x. Versões posteriores do ArcGIS podem conter diferentes funcionalidades, bem como diferentes nomes e locais para menus, comandos e ferramentas de geoprocessamento.
Nota: As informações neste artigo se aplicam a produtos desativados, ARC/INFO e ArcInfo Workstation.

Causa

Isso geralmente é causado por inconsistências ou erros na comunicação da rede. Dispositivos na rede, como switches, roteadores ou firewalls que interferem na comunicação entre o ArcGIS e o gerenciador de licença, também podem causar este problema.

Solução ou Solução Provisória

O gerenciador de licença inicia duas conexões TCP para fazer o check-in ou check-out de uma licença; um cujo padrão é a porta TCP 27005 (8.xe anterior) ou 27004 (9.0 e posterior) e uma em uma porta TCP aleatória. Essa segunda porta dinâmica/aleatória pode ser bloqueada por roteadores, switches ou firewalls na rede entre o servidor de licença e o cliente. Para aliviar esse problema, configure o gerenciador de licença para ser executado em uma segunda porta estática e, em seguida, abra essa porta em todos os dispositivos de rede intervenientes.

  1. Use um editor de texto para editar os arquivos de licença para refletir a segunda porta estática. Estes arquivos estão localizados no diretório C:\Program Files\ESRI\License para Windows e ArcGIS 8.x, e em C:\Program Files\ESRI\License\Arcgis9x for Windows e 9.x. Eles estão em $ARCHOME/sysgen para UNIX. Adicione uma PORT=#### a linha VENDOR em cada arquivo .lic ou .dat como abaixo:
Código: VENDOR ESRI PORT=####

Os usuários do ArcGIS 9.x aparecerão da seguinte forma:

Código: VENDOR ARCGIS PORT=####
Nota: Para gerenciadores de licença do Windows, cada um dos arquivos * .lic deve ser editado de forma idêntica.
  1. Salve o arquivo.
  2. Parar o License Manager.
    Para procedimento do Windows, consulte Instrução: Pare o ESRI License Manager utilizando LMTOOLS.
    Para procedimento UNIX, consulte Instrução: Pare ou inicie o Esri License Manager no UNIX.
  3. Inicie o License Manager:
    Para o procedimento do Windows, consulte o seguinte artigo da Base de Conhecimento para o procedimento, Instrução: Iniciar o ESRI License Manager utilizando LMTOOLS.
    Para procedimento UNIX, consulte Instrução: Pare ou inicie o Esri License Manager no UNIX.
  4. Certifique-se de que todos os dispositivos na rede entre o cliente e o servidor estejam configurados para permitir a porta especificada na Etapa 1.
Nota: Contate seu sistema ou administrador de rede para obter ajuda.

ID do Artigo:000006136

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